Pfsense continuously rebooting each four and a half minutes



  • I have a router build based on the Supermicro A1SRi-2758F. Everything was running smoothly until this morning. After exactly four and a half minutes I can hear and see that it is rebooting itself.

    1.) I tried hooking up a VGA cable to my TV, but it can't send a signal some how ("no signal"), so there's no way to get into the bios or anything. Any ideas on some visual feedback?
    2.) My laptop can't get an IP anymore, just a self assigned IP. Any idea on how to get in via SSH?

    How would I be able to understand what's going on? LED lights on the Supermicro A1SRi-2758F do not display anything wrong. Normally it should start beeping and changing led speeds / colors, in case something went wrong. I'm only seeing the green heart-beat LED functioning normal.

    Is it possible that it's not a hardware thing, but that somehow Pfsense is stuck? If so, how would I reinstall a machine that I'm not able to connect to? It's installed on SSD-DM032-PHI, which I also have no idea how to connect to :-)

    Any help is greatly appreciated!


  • Netgate Administrator

    You should see some output on the VGA port even if it's just the BIOS. That board has both serial and VGA console though so the output from pfSense may be primarily on the serial console if there is any.
    Check the serial port to be sure.

    4.5 minutes is an odd time. If it was stuck in a boot loop due to a filesystem issue I would expect it to reboot faster than that. It might be hardware. Try disconnecting everything. Just leave a minimal amount of RAM. If you still see nothing you probably have an issue.

    It could also be your TV can't display whatever resolution it's trying.

    Steve



  • Thank you Stephen!

    I've changed the RAM from 2 modules to a single and swapped them just to check if that made a difference. Unfortunately nothing improves. I've then decided to remove all RAM and the SATA DOM module to see if it stops rebooting, but it still does after exactly 4.5 minutes. So what can that logically mean? That the motherboard is toasted / malfunctioning? I purchased the motherboard almost exactly 3 years ago, which I consider not that many years for a supermicro motherboard... VGA is still not working, also not on a second TV I tried. I'm 100% sure that the first TV I tried it on was working though years ago.

    Any suggestion(s) would be greatly appreciated!


  • Rebel Alliance Netgate Administrator

    When you say reboot, is it a full reboot, or does the unit power off and you need to power it back on?

    Either way, I would reach out to SuperMicro, see if they have any options for you.



  • It reboots automatically, meaning you can hear the ventilator noise more loudly for a split second, a red LED lights up on the motherboard, all the control panel lights go off and then after less than a second they go on again, as well as the ventilator starts again. No manual rebooting on my side. This pattern continues every 4.5 minutes.


  • Rebel Alliance Netgate Administrator

    I have seen this in the past, a power off/reboot around the 4 minute mark. I would suggest contacting SuperMicro and requesting an RMA, it seems low level in nature.

    I know the board is old, but they might accept the RMA on it. It won't hurt you to ask:

    https://www.supermicro.com/support/rma/


  • Netgate Administrator

    Were you able to check the serial console at all?

    I've never seen it but it might be possible to disable the VGA output.

    You might try resetting the CMOS to remove anything odd like that.

    Steve



  • I'm glad that I'm not the only one!

    Just found a post that has the same symptoms:
    https://serverfault.com/questions/223003/server-reboots-every-4-5-5-5-minutes

    I will try to reset the CMOS and report back.

    Thank you sooo much guys!



  • A quick update on what I've done so far:

    Removed CMOS battery and reinserted
    Didn't work.

    Reset CMOS
    Didn't work either unfortunately.

    Checked jumper for VGA
    Is already on pin 1-2, which should enable it.

    Checked jumper for Watch Dog
    Disabled it, still rebooted after 4.5 minutes.

    I'll try the serial output next, but I first have to buy a cable. How does this work? Can I just order a "Serial to USB" cable and connect it to my Macbook? If that doesn't work I'll shoot in an RMA. I already have a support ticket running, which I hope they answer on Monday.

    Thanks again!


  • Netgate Administrator

    The 4.5mins does seem suspiciously like that watchdog reference but I would still expect to see output during that point.

    No output at all on the VGA port even after resetting the CMOS doesn't look good to be honest. This is a C2000 SoC with everything that implies.

    Connecting to the serial port usually requires a USB to serial adapter and a null-modem cable. But you can get adapters that are both those things combined.
    https://www.netgate.com/docs/pfsense/hardware/connecting-to-the-serial-console.html

    Steve


Log in to reply