XG-7100 bricked after coreboot 01.00.00.10 upgrade



  • I have an almost new pair of XG-7100's I am configuring for HA. I tried to do the coreboot upgrade from 01.00.00.07 to 01.00.00.10 on one, it looked successful, waited 24 hours and it did not reboot itself so did a power cycle as no user interfaces worked. It did not come back online on the network., I hooked up a console connection and it has a ton of errors around unable to unload librarys and DLL's. Tried option 15 - restore to a recent config - did not help. Any help would be appreciated.


  • Banned

    @kevink said in XG-7100 bricked after coreboot 01.00.00.10 upgrade:

    so did a power cycle as no user interfaces worked.

    Which likely corrupted the filesystem, reboot via console next time.

    https://www.netgate.com/docs/pfsense/solutions/xg-7100/reinstall-pfsense.html



  • Considering I was remote, and it had the option on the www interface to do this upgrade and no mention anywhere that you needed to have a console connection to properly reboot the device for this upgrade I feel this is a bug / or just a horrible implementation. I will try to get portal access to download the image and reinstall. I guess for these you just run on old code if this is the normal result.


  • Banned

    Never reboot pfSense by just switching power off, that has a very high chance of corrupting the filesystem. If something doesn't work right always connect via serial/vga console and reboot from there if you have to.

    As for why the update failed, you provided not nearly enough information to make any conclusions.

    Also for coreboot you apply the same principle as with any other BIOS update, never do it remotely, always monitor it directly on site.



  • @grimson Pretty new to these appliances, when I get an option on a WWW interface it gives the impression it is no big deal and it should just work. Your instructions make it seem more like something that is much more finicky. I do not have much more to tell you about the details, the www interface got to a point it said it was completed successfully and stayed there. I tried to go to the diagnostics -> reboot but at that point it was hung. When I got to the console after it was power cycled, which was the instructions from a Netgate documentation page that did not say use the console to try it. The www interface never came back. The errors are all around .so and .dll files not found and unable to load libraries.

    I just got a portal account and downloaded the image file, will burn it and reload the unit. See where it stands and then reload the config XML file and hopefully be back where I started.

    Thanks you for your help.


Log in to reply