Squid 3 can't be accessed from Web GUI on my pfsense 2.0 alpaha-alpha



  • Version  2.0-ALPHA-ALPHA
    built on Fri Mar 6 01:32:29 EST 2009
    FreeBSD 7.1-RELEASE-p3

    that's my present pfsense 2.0 alpha-alpha version. ever since i used 2.0 and updated so many times, i can't open my squid package from the web gui. but if will put "&" before xml (as i've read somewhere from the forum), then i can get into the squid menu. it works a little bit but will not avail squid's cache manager. i really need to configure the cache. i badly need help on this.

    Warning: fopen(/usr/local/pkg/squid_cache.xmlid=0): failed to open stream: No such file or directory in /etc/inc/xmlparse.inc on line 169 Error: could not open XML input

    please help. sir sullrich?  ::)

    a zillion thanks ahead. :)



  • My apologies, if I'm speaking out of turn here…  However, I've noticed that some of the packages that were giving me this same issue have been resolved, in recent versions.  I'm no longer running squid3, but squid instead, so I can't speak on squid3 specifically.

    I may be way out of line here, but I might suggest doing an 13) Upgrade from console, and manually type the URL for the most recent FULL upgrade (currently http://snapshots.pfsense.org/FreeBSD7/HEAD/pfSense-Full-Update-2.0-ALPHA-ALPHA-20090315-1028.tgz).

    I don't know, but it seems to be a more complete upgrade than the built-in automatic, and has corrected some other problems I've had...



  • thanks a lot. it really does have some improvements. squid3 and havp is already functioning at web gui level though not all of its menus. squid's cache manager for one, is still not there.

    again, thanks for the information. that means it's in aggressive development right now. 8)

    and of course, i will be waiting for that "cache manager" to function from it's gui. ;)

    more power to pfsense!


Log in to reply