Guest/2nd Wifi Appears to Ignore the "Standard" Setting



  • This may be a noob problem, but I would appreciate some help or advice.

    I have set up wifi and got it (relatively) stable, although the "Interface Statistics" has it's "Errors In" and "Errors Out" slowly increasing. I haven't identified the exact cause of that, but suspect that is may be because every channel where I am has between 4 and 7 different wifi points on them.

    The first wireless interface (ath0 Atheros 9287) had some teething problems, so:
    I added/set the "hw.ath.bstuck" system tuneable to "8". This was to reduce the number of "stuck beacon; resetting" I was getting in the log file.
    I increased the "Group Key Rotation" and "Group Master Key Regeneration" values (to 3600 and 7200). This was because although I could initially connect to the working wifi, overnight my devices had authentication errors and could not reconnect without having to manually reset the wifi.
    I had to change the "Standard" from "802.11ng" (the default) to "802.11g". This was because otherwise my devices would randomly loose internet connection.

    So, I have one physical wifi card, but I have added it a second time to "Interfaces / Wireless" to try to setup a Guest wifi access point. This appears to be ok.

    The problem is that when I enable it as an interface, despite setting the "Standard" to "802.11g", the wifi analyser my phone is seeing it span multiple wifi channels. Similar to what I see if i'm trying to use the "802.11ng" setting.

    Am I doing something wrong or stupid?
    Or is this a problem with the wifi drivers?

    Thanks.


  • Netgate Administrator

    Hmm, can't say I've ever checked that.
    However there is only one radio in the card it can only work at a single set of settings so you can't have values on the separate SSIDs that conflict. I expect the first SSID to dictate that and it looks like you have both set to the same thing anyway...

    Double check in ifconfig that ath0_wlan0 and ath0_wlan1 really are being set as expected.

    Errors on the wifi interface are pretty much expected unless you're operating in a very clean radio environment.

    
    WIFI Interface (opt2, ath0_wlan0)
    
    Status
        up
    MAC Address
        18:cf:5e:85:75:85
    IPv6 Link Local
        fe80::1acf:5eff:fe85:7585%ath0_wlan0
    MTU
        1500
    Media
        autoselect mode 11ng <hostap>
    Channel
        13
    SSID
        55wifinet
    BSSID
        00:1e:c0:05:45:05
    Rate
        1M
    RSSI
        3.0
    In/out packets
        5118466/18378148 (499.74 MiB/24.33 GiB)
    In/out packets (pass)
        5118466/18378148 (499.74 MiB/24.33 GiB)
    In/out packets (block)
        3171/0 (196 KiB/0 B)
    In/out errors
        744751/3094849
    Collisions
        0
    Bridge (bridge0)
        learning	
    

    Steve



  • Hi,

    Thanks for the reply.
    Looks like I might have to look through the code to try to figure out where the problem is.

    When I set up one wifi, "ifconfig" shows that the mode is 11g (which is what i set it as, the default was 11ng)

    ath0_wlan0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	ether 90:a4:de:ea:a7:0d
    	hwaddr 90:a4:de:ea:a7:0d
    	inet6 fe80::92a4:deff:feea:a70d%ath0_wlan0 prefixlen 64 scopeid 0x9 
    	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    	media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
    	status: running
    	ssid myhomewifi channel 9 (2452 MHz 11g) bssid 90:a4:de:ea:a7:0d
    	regdomain ETSI country GB indoor ecm authmode WPA2/802.11i
    	privacy MIXED deftxkey 2 AES-CCM 2:128-bit AES-CCM 3:128-bit
    	txpower 30 scanvalid 60 protmode OFF wme burst dtimperiod 1 -dfs
    	groups: wlan 
    

    after creating the second access point, when I enable it, it shows as 11ng

    ath0_wlan0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	ether 90:a4:de:ea:a7:0d
    	hwaddr 90:a4:de:ea:a7:0d
    	inet6 fe80::92a4:deff:feea:a70d%ath0_wlan0 prefixlen 64 scopeid 0x9 
    	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    	media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>
    	status: running
    	ssid myhomewifi channel 9 (2452 MHz 11g) bssid 90:a4:de:ea:a7:0d
    	regdomain ETSI country GB indoor ecm authmode WPA2/802.11i
    	privacy MIXED deftxkey 2 AES-CCM 2:128-bit AES-CCM 3:128-bit
    	txpower 30 scanvalid 60 protmode OFF wme burst dtimperiod 1 -dfs
    	groups: wlan 
    ath0_wlan1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	ether 96:a4:de:ea:a7:0d
    	hwaddr 96:a4:de:ea:a7:0d
    	inet6 fe80::94a4:deff:feea:a70d%ath0_wlan1 prefixlen 64 scopeid 0xc 
    	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    	media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>
    	status: running
    	ssid Guest channel 9 (2452 MHz 11g ht/40-) bssid 96:a4:de:ea:a7:0d
    	regdomain ETSI country GB indoor ecm authmode WPA2/802.11i
    	privacy MIXED deftxkey 2 AES-CCM 2:128-bit txpower 30 scanvalid 60
    	protmode OFF ampdulimit 64k ampdudensity 8 shortgi burst -apbridge
    	dtimperiod 1 -dfs
    	groups: wlan
    

    the first and second are definitely using different settings.
    0_1550365478467_Screenshot_20190217-004722.png


  • Netgate Administrator

    Hmm, interesting, I'm surprised it's possible to use different settings there. At least that confirms it. I assume you have it set to 11g only in the guest interface settings?

    Trying to replicate it here I find I'm unable to set either SSID to 11g mode. That could be just my hardware.

    Steve



  • FYI... As I am just using the for my home setup, I'm not too bothered about getting a second access point setup.

    I haven't had time to look at the code properly, but I have managed to narrow down where the issue may be.

    Creating, assigning and editing the interface appears to work ok.
    The values (e.g. the "ssid") are not set when we click save, but they are saved (i.e. they are still there if i re-open the web page).

    ath0_wlan1: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	ether 9e:a4:de:ea:a7:0d
    	hwaddr 9e:a4:de:ea:a7:0d
    	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    	media: IEEE 802.11 Wireless Ethernet autoselect <hostap> (autoselect <hostap>)
    	status: no carrier
    	ssid "" channel 9 (2452 MHz 11g)
    	regdomain ETSI country GB indoor ecm authmode OPEN privacy OFF
    	txpower 30 scanvalid 60 protmode OFF wme burst dtimperiod 1 -dfs
    	bintval 0
    	groups: wlan 
    

    The problem happens after we click "Apply+Changes" e.g. the "mode" has reverted to the default value (not the one that is set)

    ath0_wlan1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	ether 9e:a4:de:ea:a7:0d
    	hwaddr 9e:a4:de:ea:a7:0d
    	inet6 fe80::9ca4:deff:feea:a70d%ath0_wlan1 prefixlen 64 scopeid 0xc 
    	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    	media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>
    	status: running
    	ssid Guest channel 9 (2452 MHz 11g ht/40-) bssid 9e:a4:de:ea:a7:0d
    	regdomain ETSI country GB indoor ecm authmode WPA2/802.11i
    	privacy MIXED deftxkey 2 AES-CCM 2:128-bit txpower 30 scanvalid 60
    	protmode OFF ampdulimit 64k ampdudensity 8 shortgi burst -apbridge
    	dtimperiod 1 -dfs
    	groups: wlan 
    

    Is there an easy way to monitor what commands the web interface ends up executing?



  • The "standard" looks good in the ".interfaces.apply" file.

    The only odd thing i have noticed is that if I make changes and hit "save" i get:

    cat ./tmp/.interfaces.apply
    a:1:{s:4:"opt6";a:2:{s:5:"ifcfg";a:4:{s:5:"descr";s:4:"OPT6";s:2:"if";s:10:"ath0_wlan1";s:8:"wireless";a:8:{s:8:"standard";s:3:"11g";s:8:"protmode";s:3:"off";s:7:"channel";s:1:"9";s:8:"distance";s:0:"";s:9:"regdomain";s:0:"";s:10:"regcountry";s:2:"GB";s:11:"reglocation";s:0:"";s:4:"mode";s:6:"hostap";}s:6:"realif";s:10:"ath0_wlan1";}s:4:"ppps";a:1:{i:0;a:12:{s:5:"ptpid";s:1:"0";s:4:"type";s:5:"pppoe";s:2:"if";s:6:"pppoe0";s:5:"ports";s:4:"igb0";s:8:"username";s:19:"==REDACTED==";s:8:"password";s:16:"==REDACTED==";s:5:"descr";s:7:"==REDACTED==";s:8:"provider";s:0:"";s:9:"bandwidth";s:0:"";s:3:"mtu";s:0:"";s:3:"mru";s:0:"";s:4:"mrru";s:0:"";}}}}
    

    whereas if (without applying the change, or editing anything) I hit "save" again, i get...

     cat ./tmp/.interfaces.apply
    a:1:{s:4:"opt6";a:2:{s:5:"ifcfg";a:6:{s:5:"descr";s:5:"GWLAN";s:2:"if";s:10:"ath0_wlan1";s:8:"wireless";a:18:{s:8:"standard";s:3:"11g";s:8:"protmode";s:3:"off";s:7:"channel";s:1:"9";s:8:"distance";s:0:"";s:9:"regdomain";s:0:"";s:10:"regcountry";s:2:"GB";s:11:"reglocation";s:0:"";s:4:"mode";s:6:"hostap";s:4:"ssid";s:5:"Guest";s:8:"authmode";s:0:"";s:7:"txpower";s:0:"";s:3:"wpa";a:9:{s:11:"macaddr_acl";s:0:"";s:8:"wpa_mode";s:1:"2";s:12:"wpa_key_mgmt";s:7:"WPA-PSK";s:12:"wpa_pairwise";s:4:"CCMP";s:15:"wpa_group_rekey";s:4:"3600";s:13:"wpa_gmk_rekey";s:4:"7200";s:10:"passphrase";s:11:"==REDACTED==";s:10:"ext_wpa_sw";s:0:"";s:6:"enable";s:0:"";}s:16:"auth_server_addr";s:0:"";s:16:"auth_server_port";s:0:"";s:25:"auth_server_shared_secret";s:0:"";s:17:"auth_server_addr2";s:0:"";s:17:"auth_server_port2";s:0:"";s:26:"auth_server_shared_secret2";s:0:"";}s:6:"enable";s:0:"";s:8:"spoofmac";s:0:"";s:6:"realif";s:10:"ath0_wlan1";}s:4:"ppps";a:1:{i:0;a:12:{s:5:"ptpid";s:1:"0";s:4:"type";s:5:"pppoe";s:2:"if";s:6:"pppoe0";s:5:"ports";s:4:"igb0";s:8:"username";s:19:"==REDACTED==";s:8:"password";s:16:"==REDACTED==";s:5:"descr";s:7:"==REDACTED==";s:8:"provider";s:0:"";s:9:"bandwidth";s:0:"";s:3:"mtu";s:0:"";s:3:"mru";s:0:"";s:4:"mrru";s:0:"";}}}}
    

  • Netgate Administrator

    What do you see in /tmp/ath0_wlanX_setup.log

    The card I have shows it setting both to 11.g but actually runs at 11ng so I'm not sure it's capable of 11g.

    Steve



  • The commands look the same.

    [2.4.4-RELEASE][root@pfSense.localdomain]/tmp: cat ath0_wlan0_setup.log
    /sbin/ifconfig 'ath0_wlan0' mode '11g'
    /sbin/ifconfig 'ath0_wlan0' mode '11g' ssid 'myhomewifi' protmode 'off' channel '9' mediaopt hostap -mediaopt adhoc -hidessid -pureg -puren apbridge -mediaopt turbo wme authmode wpa wepmode off  
    /sbin/ifconfig 'ath0_wlan0' up
    
    [2.4.4-RELEASE][root@pfSense.localdomain]/tmp: cat ath0_wlan1_setup.log
    /sbin/ifconfig 'ath0_wlan1' mode '11g'
    /sbin/ifconfig 'ath0_wlan1' mode '11g' ssid 'Guest' protmode 'off' channel '9' mediaopt hostap -mediaopt adhoc -hidessid -pureg -puren -apbridge -mediaopt turbo wme authmode wpa wepmode off  
    /sbin/ifconfig 'ath0_wlan1' up
    

    The problem happens when

    ifconfig ath0_wlan1 up
    

    is called.

    [2.4.4-RELEASE][root@pfSense.localdomain]/tmp: ifconfig ath0_wlan1
    ath0_wlan1: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	ether 92:a4:de:ea:a7:0d
    	hwaddr 92:a4:de:ea:a7:0d
    	inet6 fe80::90a4:deff:feea:a70d%ath0_wlan1 prefixlen 64 tentative scopeid 0xc 
    	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    	media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
    	status: no carrier
    	ssid Guest channel 9 (2452 MHz 11g)
    	regdomain ETSI country GB indoor ecm authmode WPA2/802.11i
    	privacy OFF deftxkey 2 AES-CCM 2:128-bit txpower 30 scanvalid 60
    	protmode OFF wme burst -apbridge dtimperiod 1 -dfs
    	groups: wlan 
    [2.4.4-RELEASE][root@pfSense.localdomain]/tmp: ifconfig ath0_wlan1 up
    [2.4.4-RELEASE][root@pfSense.localdomain]/tmp: ifconfig ath0_wlan1
    ath0_wlan1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	ether 92:a4:de:ea:a7:0d
    	hwaddr 92:a4:de:ea:a7:0d
    	inet6 fe80::90a4:deff:feea:a70d%ath0_wlan1 prefixlen 64 scopeid 0xc 
    	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    	media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>
    	status: running
    	ssid Guest channel 9 (2452 MHz 11g ht/40-) bssid 92:a4:de:ea:a7:0d
    	regdomain ETSI country GB indoor ecm authmode WPA2/802.11i
    	privacy OFF deftxkey 2 AES-CCM 2:128-bit txpower 30 scanvalid 60
    	protmode OFF ampdulimit 64k ampdudensity 8 shortgi wme burst -apbridge
    	dtimperiod 1 -dfs
    	groups: wlan 
    

    Thanks for all your help.


  • Netgate Administrator

    Hmm, that's weird. Like it forgot the value somehow. I assume ath0_wlan0 does not do that when you 'UP' it?

    I'll try and find a card that can run at 11g at all....

    Steve


Log in to reply