Squid problems: Assistance please



  • I'm running PFsense 1.22 with squid (2.6 or 3.0, i've tried both)

    The config i've got is pretty simple.

    Router -> PFsense WAN port -> PFsense LAN port -> Rest of network

    The problem i'm having is with the squid package.

    My setup in there is simple:
    LAN interface is selected
    allow users on interface is ticked
    transparent proxy is ticked
    port is 3128 (default)
    Access control (subnets) is set to 192.168.1.0/24

    On squid 2.6.21_08, the internet just stops working. If i untick allow users, it works fine but without the proxy.
    On squid 3.0, with or without the box ticked, the internet just bypasses the proxy.

    I'd like some help in setting this up, 2.6 seems to work but doesnt allow web access… is there something i've missed?



  • On mine I had that issue as well. I think what did it is that I also checked the box that said "Disable X-Forwarding". Worth a shot.



  • @undertakingyou:

    On mine I had that issue as well. I think what did it is that I also checked the box that said "Disable X-Forwarding". Worth a shot.

    Thank you for taking the time to help.

    i tried that setting, and it didnt work. Any other ideas?



  • Do you have your webGUI set to HTTPS/443?  If it's still on HTTP/80, transparent will obviously not work.



  • @mhab12:

    Do you have your webGUI set to HTTPS/443?  If it's still on HTTP/80, transparent will obviously not work.

    I think you may have found the problem!

    A new problem is that i have no idea how to change that… i'm rather new to this.

    Could you please tell me where this option is?



  • System/General in the web GUI.



  • @mhab12:

    System/General in the web GUI.

    Thanks for the help, but it didnt work.
    I changed that setting to the settings you suggested, and it made no difference. Once i tick "allow users on interface" all web page loads time out.


Log in to reply