Multicast Routing



  • Hello,

    I have been trying to use multicast routing between VLANs on the latest pfsense release and it seems the mulitcast routing is not enabled in the kernel.

    Logging into the router through ssh and opening a shell, I see the following:

    [2.4.4-RELEASE][admin@router]/root: netstat -gs4
    No IPv4 MROUTING kernel support.
    [2.4.4-RELEASE][admin@router]/root: uname -a
    FreeBSD router64.vortex 11.2-RELEASE-p6 FreeBSD 11.2-RELEASE-p6 #3 518496b29ae(RELENG_2_4_4): Wed Dec 12 07:41:44 EST 2018     root@buildbot2.nyi.netgate.com:/build/ce-crossbuild-244/obj/amd64/ZfGpH5cd/build/ce-crossbuild-244/pfSense/tmp/FreeBSD-src/sys/pfSense  amd64
    [2.4.4-RELEASE][admin@router]/root: kldstat
    Id Refs Address            Size     Name
     1    8 0xffffffff80200000 2d9a7d0  kernel
     2    1 0xffffffff83511000 10a0     cpuctl.ko
     3    1 0xffffffff83513000 72b8     aesni.ko
     4    1 0xffffffff8351b000 c88      coretemp.ko
    

    How can the multicast routing be enabled, is there a kernel module which can be loaded with kldload (I've read at http://troglobit.com/howto/mrouting-in-freebsd/ that a module called ip_mroute should be loaded in the kernel or the kernel should be rebuilt with ip_mroute_load="yes"

    Am I missing something?

    Thanks for the help.



  • I'm also trying to follow a guide to get pimd running on pfsense.
    http://troglobit.com/howto/pimd-on-freebsd/

    netstat -gs returns

    No IPv4 MROUTING kernel support.
    

    I first tried loading the module manually.
    kldload -v ip_mroute
    Received a missing module error.

    Since it was missing. I copied the module ip_mroute.ko from a freebsd install (frome the same base freebsd version used for pfsense 2.4.4).
    I placed that file in /boot/modules
    I added the line ip_mroute_load="yes" to the /boot/loader.conf.local file.
    Rebooted.
    And unfortunately, I still get "No IPv4 MROUTING kernel support", from the netstat -gs command.

    Now when when i manually try "kldload -v ip_mroute" i get this error.

    kldload: can't load ip_mroute: module already loaded or in kernel
    

    Not sure what do try next....



  • hmmmm. I just noticed that when i run kldstat
    this is the output.

    Id Refs Address            Size     Name
     1   19 0xffffffff80200000 2d9a7d0  kernel
     2    1 0xffffffff82f9c000 382180   zfs.ko
     3    2 0xffffffff8331f000 a3b0     opensolaris.ko
     4    1 0xffffffff8332a000 14be8    ip_mroute.ko
     5    1 0xffffffff83421000 10a0     cpuctl.ko
     6    1 0xffffffff83423000 72b8     aesni.ko
     7    1 0xffffffff8342b000 c88      coretemp.ko
    

    So it does look like ip_mroute.ko is loaded now.
    But am stil getting the "No IPv4 MROUTING kernel support" from "nestat -gs".



  • Hi,

    I have the same problem.
    Have you found a solution ?

    Thanks,

    Sam



  • Same problem here, on 2.4.4-RELEASE-p2.

    I'm trying to follow this guide (https://forum.netgate.com/topic/139218/sonos-speakers-and-applications-on-different-subnets-vlan-s) about pimd, but I can't make it work. I think it may be due to this missing module.



  • @pponce said in Multicast Routing:

    ip_mroute.ko

    https://redmine.pfsense.org/issues/9631

    JimP closed this particular redmine with the comment that a pimd package would be the way to go. Maybe a bounty in order??

    Anyone have a copy of ip_mroute they can give me for 2.4.4? (freebsd v 11.2) or 2.5 (12)

    Edit- ip_mroute is actually in the pimd package contents. Though it is from 2012..


Log in to reply