Shared object "libssl.so.111" not found



  • Hi Guys,

    i have the newest pfSense release installed.
    Currently I am testing a few things and need the "libssl.so.111", because I am running the following error message while executing a framework (not known, I just test it out):

    Shared object "libssl.so.111" not found, required by "FRAMEWORK"

    I've already googled, but could not find a solution to explicitly install this library.

    Does somebody has any idea?


  • Rebel Alliance Developer Netgate

    Sounds like that wants OpenSSL/LibSSL 1.1.1 which isn't available on pfSense 2.4.x.

    Maybe you copied a package from the wrong FreeBSD version (for example, you grabbed a FreeBSD 12.0 package when you need a FreeBSD 11.2 package)



  • Is there any way to install this lib later?



  • A FreeBSD package, call it OpenVPN 1.1.1 or FRAMEWORK, or whatever, compiled against FreeBSD 12.0, will function when the host OS is FreeBSD 12.0

    The newer OpenVPN will be included when pfSense is based on FreeBSD 12.0, and this will be pfSense 2.4.5 - see https://forum.netgate.com/topic/140586/heads-up-snapshots-moving-to-pfsense-2-5-0-on-freebsd-12-expect-initial-instability



  • Sounds good. So the lib 1.1.1 is not running on freeBSD 11.2?
    Have i understand it right this way?

    And the solution is to wait for the freeBSD 12.0 release?



  • Well, you could find this "1.1.1 lib" in the FreeBSD package repository.
    Put in in place and see what happens .... ;)

    A good solution is always to use software compiled for OS "something" on OS "something", not OS "other thing".
    You could override this rule of course.
    In that case, check the source, see what dependencies it has, if needed, recompile the software on the "other thing" OS, etc.

    Btw : pfSEnse is not some host OS to try out some packages. In that case, install FreeBSD directly.
    pfSense packages which are based on FreeBSD packages use the 11.2 version right now.



  • @gertjan said in Shared object "libssl.so.111" not found:

    Btw : pfSEnse is not some host OS to try out some packages. In that case, install FreeBSD directly.
    pfSense packages which are based on FreeBSD packages use the 11.2 version right now.

    Absolute! I'm just testing out a few things and therefore need the lib.

    It's like testing out a framework that I did not develop. However, this framework requires the libssl1.1.1

    It will definitely not be productive, I just want to be able to use the framework.
    If the lib is available in the new release then it is fine everything :)

    Thank you!


  • Rebel Alliance Developer Netgate

    What "things" are you testing out and where did you get them?

    What FreeBSD version are these things compiled against?

    There may be a lot more hurdles than this one library.



  • I do not want to be rude and thank you very much for your support.
    But I would just like to know how to install the lib later :)

    Unfortunately, I am not the developer, but I just want to test it out.

    I would be very grateful if you could tell me how to get the lib on the system.
    thank you and best regards :)



  • As said before.

    More details this time :
    Install the required OS first : FreeBSD. Get it from here : https://www.freebsd.org/where.html
    Then install the FreeBSD package OpenSSL ( I needed 3 seconds to find info like https://forums.freebsd.org/threads/upgrade-openssl-1-0-2-1-1-1.67560/ )

    Now you will have, the correct setup to test your FRAMEWORK.


  • Rebel Alliance Developer Netgate

    You aren't being rude, you are withholding required information, which is only hurting yourself. Before we can tell you where to get the correct version of the library, you need to answer the questions I asked. Not because we're being nosy, but because without knowing that, you could install the wrong one and cause harm to your firewall (at worst) or have a broken application (at best).

    For example: pfSense 2.4.4-p2 is based on FreeBSD 11.2. Your application and the library you are seeing must also be compiled for FreeBSD 11.2. If your application is compiled against FreeBSD 12, it's likely to fail.

    If you don't want to answer any questions, then the solution is: Get it from FreeBSD. If you need more guidance than that, you need to cooperate, or this thread is useless.


Log in to reply