Recover pfSense files from SSD



  • Unfortunately my Netgate SG-8860-1U has died and I need to access files on the SSD as it contained a number of custom scripts and squid ACL files which I don't have backed up.

    I've tried using the pfSense-CE-memstick-2.4.4-RELEASE-p1-amd64.img with the drive in another PC and booting into rescue mode, however when I look through the boot dmesg log the SSD isn't being recognised at all. I've tried booting via both UEFI and legacy BIOS. The SSD is recognised in the BIOS as I can see it listed.

    Appreciate any suggestions of how I can mount and access the files on the drive?


  • LAYER 8 Rebel Alliance

    Get FreeBSD-11.2-RELEASE-amd64-bootonly.iso and boot in into Live mode. User is root with no password in Live mode.
    Search your disk with

    geom disk list
    

    then mount the partition

    mount /dev/da0s1 /mnt
    cd /mnt
    ls -l
    

    done. ☺

    -Rico


  • Netgate Administrator

    Which SSD type is it? mSATA or 2.5" SATA?

    If it's mSATA be sure the slot you are using in the other machine is actually mSATA and not mPCIe.

    Steve


Log in to reply