(Install) files blocked when downloading via shell (browser OK)



  • The may be the wrong place to post this, but slightly related. I have a CARP setup. I decided to rebuild from scratch for clean install and to reorganize. I need to 'side load' an application (upgrade to approved application). The files download like they should from the shell on the backup node. However, they are blocked on the master node. I can download the files from a website on the master node. I've tried changing the IP addresses. I tried moving the node VM to the same host as the backup node. With everything I''ve tried, I think there must be some setting in pfSense that is blocking the file download via the shell console (I also tried SSH - same result). Does anyone have an idea what it might be? It's driving me nuts.


  • Rebel Alliance Developer Netgate

    What is the exact error message you receive? "blocked" tells us nothing about what is really happening.

    Which node is currently MASTER for the CARP VIPs?

    Did you maybe make your outbound rules too loose (e.g. source of * / any)?



  • The error is 'No address record'

    The issue is on the master node. I tried it both when it was acting as master and when it had CARP disabled, making the backup the master. Either way didn't seem to matter.

    It's just weird that it works fine on the backup node, but not the master node, regardless of the status they are in.


  • Rebel Alliance Developer Netgate

    "No address record" means one of two things:

    1. It can't reach the Internet, typically because there is no default gateway in the routing table. Check your gateway settings, make sure the default is set as expected, then save/apply. If you are using a gateway group as default, try it with a single WAN gateway. Look under Diagnostics > Routes and see if you have a default listed.
    2. Your DNS settings are not correct or it otherwise cannot reach upstream DNS servers.

Log in to reply