Restore feature broken?



  • i might be completely misunderstanding the way that backup/restore are supposed to work.  the issues i have is this.

    i choose to backup "everything"  minus the package information.
    i blow out pfsense, reinstall it etc.
    if i try to do a restore on shaper information, i get a message that tells me it can't find that information in the xml file that i point it at to restore from.
    should restore not be able to take in the entire xml file, and then only restore the section you want to the active config within pfsense?
    it allows me to restore if i make a separate file that only contains the <shaper>tags just fine. is this a bug ?</shaper>



  • No, you have it all wrong.  You can only restore a section IF you exported a section to begin with!

    You cannot export the entire configuration and then specify only traffic shaper.  It tries to import the entire configuration into the traffic shaper config only and it WILL go boom.



  • @sullrich:

    No, you have it all wrong.  You can only restore a section IF you exported a section to begin with!

    You cannot export the entire configuration and then specify only traffic shaper.  It tries to import the entire configuration into the traffic shaper config only and it WILL go boom.

    I tried to do this as well. Wouldn't it be possible for it to just parse the xml on import and just grab the section it needs. This would be useful to add.



  • I backed up the complete config, restored it and it wouldn't let me create any more rules. So I'm not sure if it is working… then again, it's been giving me hell today, so maybe its the platform (old Dell desktop).


Locked