SG-3100 recovery issue



  • SG-3100 had {place unknown issue here} , which ended in corruption. I grabbed the factory recovery image and ran :

    run recovery
    
    FreeBSD/arm (sg-3100-recovery) (ttyu0)
    
    Last login: Mon Mar  4 15:05:24 on ttyu0
    FreeBSD 11.2-RELEASE-p6 (ARMADA38X) #5 ed5153fb2b9(factory-RELENG_2_4_4): Wed Dec 12 14:51:19 EST 2018
    
            __
     _ __  / _|___  ___ _ __  ___  ___
    | '_ \| |_/ __|/ _ \ '_ \/ __|/ _ \
    | |_) |  _\__ \  __/ | | \__ \  __/
    | .__/|_| |___/\___|_| |_|___/\___|
    |_|
    
    
    Welcome to pfSense 2.4.4-RELEASE2...
    
    Netgate SG-3100 firmware recovery
    Serial: 1112184584
    
    This will install the standard firmware and will erase all the existing
    contents of the destination device permanently.
    
    eMMC device: mmcsd0
    
    M.2 device: ada0
    
    
    Type the name of the destination device (mmcsd0,ada0) or type enter to install on mmcsd0: ada0
    
    Selected M.2 device: ada0
    
    Are you sure you want to continue ? (y/N) y
    
    Erasing the M.2 contents...
    Writing the firmware to M.2...
    (this may take a few minutes to complete)
    
    mount: /dev/diskid/DISK-CEF032182300501s2a: R/W mount of / denied. Filesystem is not clean - run fsck. Forced mount will invalidate journal contents: Operation not permitted
    
    error mounting pfSense partition.  aborting.
    
    
    
    ***** FILE SYSTEM MARKED CLEAN *****
    ERROR: Impossible to mount filesystem, use interactive shell to attempt to recover it
    
    

    Running fsck a dozen times selecting use or not use journal and or recover files accomplished nothing

    Attempting to manually unmount disks or filesystems is futile

    I would beat the msata up with gpart , and do a fresh install, if possible, again, assuming the issue is with the operator before doing so.

    Suggestions?



  • If I had looked .............

    The factory image was installed on mmcsd0, recovery went well.

    Now to install the proper image to the msata card

    I, for some reason assumed ordering sg-3100 would have been install on the msata, not so much.
    This time assuming made an a** out of me alone.



  • At this point I am searching to see if the factory restore image can be installed.

    Attempting to use the restore image to install on the msata drive is the same results as in my initial post.

    Or if the msata drive gave up the ghost.


  • Netgate Administrator

    Was this supplied with the m.2 SSD? If so it certainly should have been installed there.

    The installer should reformat the SSD, no filesystem corruption can be carried through that.

    Did that appear to install correctly and then throw the error?

    Steve



  • @stephenw10 said in SG-3100 recovery issue:

    Was this supplied with the m.2 SSD? If so it certainly should have been installed there.

    The installer should reformat the SSD, no filesystem corruption can be carried through that.

    Did that appear to install correctly and then throw the error?

    Steve

    The unit was purchased 7-13-2018, yes the M.2 SSD was purchased with the SG-3100
    Order Number:78731
    Here is the output

    Marvell>> run recovery
    (Re)start USB...
    USB0:   mvBoardUsbVbusSet: gppNo = 35
    Port (usbActive) : 1	Interface (usbType = 3) : USB XHCI 1.00
    scanning bus 0 for devices... 2 USB Device(s) found
           scanning usb for storage devices... 1 Storage Device(s) found
           scanning usb for ethernet devices... 0 Ethernet Device(s) found
    reading ubldr.bin
    228664 bytes read in 36 ms (6.1 MiB/s)
    ## Starting application at 0x00200000 ...
    Consoles: U-Boot console  
    Compatible U-Boot API signature found @0x7f4dc280
    
    FreeBSD/armv6 U-Boot loader, Revision 1.2
    (Wed Nov 21 10:06:26 EST 2018 root@buildbot2.nyi.netgate.com)
    
    DRAM: 2048MB
    Number of U-Boot devices: 5
    U-Boot env: loaderdev not set, will probe all devices.
    Found U-Boot device: disk
      Probing all disk devices...
      Checking unit=0 slice=<auto> partition=<auto>...disk0: read failed, error=1
    
      Checking unit=1 slice=<auto> partition=<auto>... good.
    Booting from disk1s2a:
    |
    /boot/kernel/kernel data=0x815b18+0x6e4e8 syms=[0x4+0x7ed90+0x4+0xb32bf]
    Hit [Enter] to boot immediately, or any other key for command prompt.
    Booting [/boot/kernel/kernel]...               
    /boot/dtb/armada-385-80300-0148-G00-X100.dtb size=0x5307
    Loaded DTB from file 'armada-385-80300-0148-G00-X100.dtb'.
    Kernel entry at 0x400100...
    Kernel args: (null)
    Copyright (c) 1992-2018 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    	The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 11.2-RELEASE-p6 #5 ed5153fb2b9(factory-RELENG_2_4_4): Wed Dec 12 14:51:19 EST 2018
        root@buildbot2.nyi.netgate.com:/build/factory-crossbuild-244/obj/armv6/rWTablOZ/arm.armv6/build/factory-crossbuild-244/pfSense/tmp/FreeBSD-src/sys/ARMADA38X arm
    FreeBSD clang version 6.0.0 (tags/RELEASE_600/final 326565) (based on LLVM 6.0.0)
    CPU: ARM Cortex-A9 r4p1 (ECO: 0x00000000)
    CPU Features: 
      Multiprocessing, Thumb2, Security, VMSAv7, Coherent Walk
    Optional instructions: 
      UMULL, SMULL, SIMD(ext)
    LoUU:2 LoC:2 LoUIS:2 
    Cache level 1:
     32KB/32B 4-way data cache WB Read-Alloc Write-Alloc
     32KB/32B 4-way instruction cache Read-Alloc
    real memory  = 2147479552 (2047 MB)
    avail memory = 2092539904 (1995 MB)
    SOC: Marvell 88F6820, TClock 250MHz, Frequency 1600MHz
      Instruction cache prefetch enabled, data cache prefetch disabled
    FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
    random: entropy device external interface
    ofwbus0: <Open Firmware Device Tree>
    simplebus0: <Flattened device tree simple bus> on ofwbus0
    simplebus1: <Flattened device tree simple bus> on simplebus0
    l2cache0: <PL310 L2 cache controller> mem 0x8000-0x8fff on simplebus1
    l2cache0: cannot allocate IRQ, not using interrupt
    l2cache0: Part number: 0x3, release: 0x9
    l2cache0: L2 Cache enabled: 1024KB/32B 16 ways
    gic0: <ARM Generic Interrupt Controller> mem 0xd000-0xdfff,0xc100-0xc1ff on simplebus1
    gic0: pn 0x390, arch 0x1, rev 0x2, implementer 0x43b irqs 192
    mpic0: <Marvell Integrated Interrupt Controller> mem 0x20a00-0x20ccf,0x21870-0x21b6f irq 19 on simplebus1
    mp_tmr0: <ARM MPCore Timers> mem 0xc200-0xc21f irq 3 on simplebus1
    Timecounter "MPCore" frequency 800000000 Hz quality 800
    mp_tmr1: <ARM MPCore Timers> mem 0xc600-0xc61f irq 4 on simplebus1
    Event timer "MPCore" frequency 800000000 Hz quality 1000
    cesa0: <Marvell Cryptographic Engine and Security Accelerator> mem 0x90000-0x90fff,0x9d000-0x9dfff irq 1 on simplebus1
    cesa1: <Marvell Cryptographic Engine and Security Accelerator> mem 0x92000-0x92fff,0x9f000-0x9ffff irq 2 on simplebus1
    spi0: <Marvell SPI controller> mem 0x10600-0x1064f irq 5 on simplebus1
    twsi0: <Marvell Integrated I2C Bus Controller> mem 0x11000-0x1101f irq 7 on simplebus1
    iicbus0: <OFW I2C bus> on twsi0
    iic0: <I2C generic I/O> on iicbus0
    gpio0: <NXP PCA9552 LED driver> at addr 0xc0 on iicbus0
    device_attach: gpio0 attach returned 6
    gpio0: <ISSI IS31FL3199 9 channel light effect LED driver> at addr 0xce on iicbus0
    gpiobus0: <OFW GPIO bus> on gpio0
    gpioc0: <GPIO controller> on gpio0
    gpio1: <NXP PCA9552 LED driver> at addr 0xc0 on iicbus0
    device_attach: gpio1 attach returned 6
    uart0: console (-1,n,8,1)le> mem 0x12000-0x120ff irq 9 on simplebus1
    uart1: <16550 or compatible> mem 0x12100-0x121ff irq 10 on simplebus1
    wdt0: <Marvell Watchdog Timer> mem 0x20300-0x20333,0x20704-0x20707,0x18260-0x18263 on simplebus1
    pmsu0: <Power Management Service Unit> mem 0x22000-0x22fff on simplebus1
    mvneta0: <NETA controller> mem 0x30000-0x33fff irq 26 on simplebus1
    mvneta0: version is 10
    mvneta0: Ethernet address: 00:08:a2:0d:9a:f3
    miibus0: <MII bus> on mvneta0
    ukphy0: <Generic IEEE 802.3u media interface> PHY 1 on miibus0
    ukphy0:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, auto
    mvneta1: <NETA controller> mem 0x34000-0x37fff irq 27 on simplebus1
    mvneta1: version is 10
    mvneta1: Ethernet address: 00:08:a2:0d:9a:f4
    mdio0: <MDIO> on mvneta1
    e6000sw0: <Marvell 88E6141> on mdio0
    e6000sw0: single-chip addressing mode
    miibus1: <MII bus> on e6000sw0
    e1000phy0: <Marvell 88E1000 Gigabit PHY> PHY 17 on miibus1
    e1000phy0:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, auto
    miibus2: <MII bus> on e6000sw0
    e1000phy1: <Marvell 88E1000 Gigabit PHY> PHY 18 on miibus2
    e1000phy1:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, auto
    miibus3: <MII bus> on e6000sw0
    e1000phy2: <Marvell 88E1000 Gigabit PHY> PHY 19 on miibus3
    e1000phy2:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, auto
    miibus4: <MII bus> on e6000sw0
    e1000phy3: <Marvell 88E1000 Gigabit PHY> PHY 20 on miibus4
    e1000phy3:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, auto
    e6000sw0: switch is ready.
    etherswitch0: <Switch controller> on e6000sw0
    ehci0: <Marvell Integrated USB 2.0 controller> mem 0x58000-0x584ff irq 28 on simplebus1
    usbus0: EHCI version 1.0
    usbus0 on ehci0
    mvneta2: <NETA controller> mem 0x70000-0x73fff irq 29 on simplebus1
    mvneta2: version is 10
    mvneta2: Ethernet address: 00:08:a2:0d:9a:f5
    miibus5: <MII bus> on mvneta2
    ukphy1: <Generic IEEE 802.3u media interface> PHY 0 on miibus5
    ukphy1:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, auto
    rtc0: <Marvell Integrated RTC> mem 0xa3800-0xa381f,0x184a0-0x184ab irq 30 on simplebus1
    rtc0: registered as a time-of-day clock, resolution 1.000000s
    ahci0: <Marvell AHCI Controller> mem 0xa8000-0xa9fff irq 31 on simplebus1
    ahci0: AHCI v1.00 with 2 6Gbps ports, Port Multiplier supported with FBS
    ahci0: quirks=0x200010<2CH,MRVL_SR_DEL>
    ahcich0: <AHCI channel> at channel 0 on ahci0
    ahcich1: <AHCI channel> at channel 1 on ahci0
    armada_thermal0: <Armada380 Thermal Control> mem 0xe4078-0xe407b,0xe4074-0xe4077 on simplebus1
    sdhci_fdt0: <ARMADA38X SDHCI controller> mem 0xd8000-0xd8fff,0xdc000-0xdc0ff,0x18454-0x18457 irq 34 on simplebus1
    sdhci_fdt0: 1 slot(s) allocated
    xhci0: <Marvell Integrated USB 3.0 controller> mem 0xf8000-0xfbfff,0xfc000-0xfffff irq 36 on simplebus1
    xhci0: 32 bytes context size, 32-bit DMA
    usbus1 on xhci0
    pcib_ctrl0: <Marvell Integrated PCIe Bus Controller> on simplebus0
    pcib0: <Marvell Integrated PCI/PCI-E Controller> on pcib_ctrl0
    pci0: <PCI bus> on pcib0
    pcib1: <Marvell Integrated PCI/PCI-E Controller> on pcib_ctrl0
    pci1: <PCI bus> on pcib1
    pcib2: <Marvell Integrated PCI/PCI-E Controller> on pcib_ctrl0
    pci2: <PCI bus> on pcib2
    pcib3: <Marvell Integrated PCI/PCI-E Controller> on pcib_ctrl0
    pci3: <PCI bus> on pcib3
    cpulist0: <Open Firmware CPU Group> on ofwbus0
    cpu0: <Open Firmware CPU> on cpulist0
    cpu1: <Open Firmware CPU> on cpulist0
    cryptosoft0: <software crypto>
    Timecounters tick every 1.000 msec
    spibus0: <OFW SPI bus> on spi0
    mx25l0: <M25Pxx Flash Family> at cs 0 mode 0 on spibus0
    mx25l0: device type n25q128, size 16384K in 256 sectors of 64K, erase size 4K
    mvneta1: link state changed to UP
    e6000sw0port1: link state changed to DOWN
    e6000sw0port2: link state changed to DOWN
    e6000sw0port3: link state changed to DOWN
    e6000sw0port4: link state changed to DOWN
    usbus0: 480Mbps High Speed USB v2.0
    usbus1: 5.0Gbps Super Speed USB v3.0
    ugen0.1: <Marvell EHCI root HUB> at usbus0
    uhub0: <Marvell EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus0
    ugen1.1: <Marvell XHCI root HUB> at usbus1
    uhub1: <Marvell XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus1
    uhub1: 2 ports with 2 removable, self powered
    ada0 at ahcich1 bus 0 scbus1 target 0 lun 0
    ada0: <NT-32 Q0927A> ACS-2 ATA SATA 3.x device
    mmc0: <MMC/SD bus> on sdhci_fdt0
    ada0: Serial Number CEF032182300501
    ada0: 600.000MB/s transfers (SATA 3.x, UDMA6, PIO 512bytes)
    ada0: 30029MB (61500000 512 byte sectors)
    mmcsd0: 8GB <MMCHC M32508 0.1 SN 014C5BD4 MFG 01/2018 by 112 0x0000> at mmc0 50.0MHz/8bit/65535-block
    mmcsd0boot0: 4MB partion 1 at mmcsd0
    mmcsd0boot1: 4MB partion 2 at mmcsd0
    mmcsd0rpmb: 4MB partion 3 at mmcsd0
    Release APs
    Trying to mount root from ufs:/dev/ufsid/5c1166ca361436f5 [rw,noatime]...
    Root mount waiting for: usbus1 usbus0
    uhub0: 1 port with 1 removable, self powered
    Root mount waiting for: usbus1
    Root mount waiting for: usbus1
    ugen1.2: <PNY USB 2.0 FD> at usbus1
    umass0 on uhub1
    umass0: <PNY USB 2.0 FD, class 0/0, rev 2.00/1.00, addr 1> on usbus1
    mountroot: waiting for device /dev/ufsid/5c1166ca361436f5...
    da0 at umass-sim0 bus 0 scbus2 target 0 lun 0
    da0: <PNY USB 2.0 FD PMAP> Removable Direct Access SPC-2 SCSI device
    da0: Serial Number 070189AB06D97D91
    da0: 40.000MB/s transfers
    da0: 14808MB (30326784 512 byte sectors)
    da0: quirks=0x2<NO_6_BYTE>
    random: unblocking device.
    Starting file system checks:
    /dev/ufsid/5c1166ca361436f5: FILE SYSTEM CLEAN; SKIPPING CHECKS
    /dev/ufsid/5c1166ca361436f5: clean, 140059 free (43 frags, 17502 blocks, 0.0% fragmentation)
    Setting hostuuid: 32c143f7-3e81-11e9-91ab-0008a20d9af3.
    Setting hostid: 0xc4546940.
    Mounting local filesystems:.
    Setting hostname: sg-3100-recovery.
    Setting up harvesting: [UMA],[FS_ATIME],SWI,INTERRUPT,NET_NG,NET_ETHER,NET_TUN,MOUSE,KEYBOARD,ATTACH,CACHED
    Feeding entropy: .
    Starting Network: lo0 mvneta0 mvneta1 mvneta2.
    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mmvneta0: link state changed to DOWN
    etric 0 mtu 16384
    	options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCmvneta2: link state changed to DOWN
    gic0: Spurious interrupt detected: last irq: 44 on CPU0
    SUM_IPV6>
    	inet6 ::1 prefixlen 128 
    	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x9 
    	inet 127.0.0.1 netmask 0xff000000 
    	groups: lo 
    	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    mvneta0: flags=8a02<BROADCAST,ALLMULTI,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	options=800bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,LINKSTATE>
    	ether ------------------------ snip
    	hwaddr ------------------ snip
    	media: Ethernet autoselect (none)
    	status: no carrier
    	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    mvneta1: flags=8a02<BROADCAST,ALLMULTI,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	options=bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM>
    	ether ------------------------- snip
    	hwaddr ------------------------ snip
    	media: Ethernet 2500Base-KX <full-duplex>
    	status: active
    	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    mvneta2: flags=8a02<BROADCAST,ALLMULTI,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	options=800bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,LINKSTATE>
    	ether -------------------------- snip
    	hwaddr ------------------------ snip
    	media: Ethernet autoselect (none)
    	status: no carrier
    	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    ELF ldconfig path: /lib /usr/lib /usr/lib/compat
    Soft Float compatibility ldconfig path:
    Starting devd.
    Starting Network: mvneta0.
    mvneta0: flags=8a02<BROADCAST,ALLMULTI,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	options=800bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,LINKSTATE>
    	ether ---------------------------- snip
    	hwaddr ------------------------------ snip
    	media: Ethernet autoselect (none)
    	status: no carrier
    	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    Starting Network: mvneta1.
    mvneta1: flags=8a02<BROADCAST,ALLMULTI,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	options=bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM>
    	ether ------------------------snip
    	hwaddr ------------------------ snip
    	media: Ethernet 2500Base-KX <full-duplex>
    	status: active
    	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    Starting Network: mvneta2.
    mvneta2: flags=8a02<BROADCAST,ALLMULTI,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	options=800bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,LINKSTATE>
    	ether ---------------------------- snip
    	hwaddr -------------------------- snip
    	media: Ethernet autoselect (none)
    	status: no carrier
    	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    add host 127.0.0.1: gateway lo0 fib 0: route already in table
    add host ::1: gateway lo0 fib 0: route already in table
    add net fe80::: gateway ::1
    add net ff02::: gateway ::1
    add net ::ffff:0.0.0.0: gateway ::1
    add net ::0.0.0.0: gateway ::1
    Creating and/or trimming log files.
    Starting syslogd.
    Clearing /tmp (X related).
    Updating motd:.
    Mounting late filesystems:.
    Starting cron.
    
    Mon Mar  4 22:10
    FreeBSD/arm (sg-3100-recovery) (ttyu0)
    
    Last login: Mon Mar  4 18:08:44 on ttyu0
    FreeBSD 11.2-RELEASE-p6 (ARMADA38X) #5 ed5153fb2b9(factory-RELENG_2_4_4): Wed Dec 12 14:51:19 EST 2018
    
            __
     _ __  / _|___  ___ _ __  ___  ___
    | '_ \| |_/ __|/ _ \ '_ \/ __|/ _ \
    | |_) |  _\__ \  __/ | | \__ \  __/
    | .__/|_| |___/\___|_| |_|___/\___|
    |_|
    
    
    Welcome to pfSense 2.4.4-RELEASE2...
    
    Netgate SG-3100 firmware recovery
    Serial: ---------------- snip
    
    This will install the standard firmware and will erase all the existing
    contents of the destination device permanently.
    
    eMMC device: mmcsd0
    
    M.2 device: ada0
    
    
    Type the name of the destination device (mmcsd0,ada0) or type enter to install on mmcsd0: ada0
    
    Selected M.2 device: ada0
    
    Are you sure you want to continue ? (y/N) y
    
    Erasing the M.2 contents...
    Writing the firmware to M.2...
    (this may take a few minutes to complete)
    0+15259 records in
    238+1 records out
    1000000000 bytes transferred in 30.770239 secs (32498936 bytes/sec)
    Fixing M.2 labels...
    mount: /dev/diskid/DISK-CEF032182300501s2a: R/W mount of / denied. Filesystem is not clean - run fsck. Forced mount will invalidate journal contents: Operation not permitted

  • Netgate Administrator

    Ok, that's a problem!
    Please open a ticket with us if you haven't already: https://go.netgate.com

    Steve



  • @stephenw10 said in SG-3100 recovery issue:

    Ok, that's a problem!
    Please open a ticket with us if you haven't already: https://go.netgate.com

    Steve

    I've reset the password, still not letting me log in to start a ticket?


  • Netgate Administrator

    If you have never used the ticket system before just create a new account, use the 'sign up' button at the bottom of the right column there.

    Steve



  • @stephenw10 said in SG-3100 recovery issue:

    If you have never used the ticket system before just create a new account, use the 'sign up' button at the bottom of the right column there.

    Steve

    Thanks, I was using my Netgate account as ID
    Ticket submitted


Log in to reply