Netgate XG-7100 - ix1 (SFP+) - can get DHCP lease but not internet connectivity?



  • I have a Netgate XG-7100.

    I'm using one of the SFP+ ports (ix0) for WAN connectivity, and the second SFP+ port (ix1) to connect to a downstream switch (Arista).

    The copper Ethernet ports on the XG-7100 are working correctly, and I can get a DHCP lease and also internet connectivity. So internet access seems to be working from the router itself.

    The Arista switch is configured with port 1 as a trunk port, and port 17 as an access port, tagged VLAN 12.

    When I connect in to port 17 on the switch - I can get a DHCP lease from pfSense - but am unable to get internet connectivity?

    This is my interface assignments - "Proxmox_VM_Traffic" is the problematic one:

    0_1551907069781_Screen Shot 2019-03-07 at 8.11.54 am.png

    This is my VLAN configuration - it's VLAN 12 that isn't working:

    0_1551907103374_Screen Shot 2019-03-07 at 8.11.57 am.png

    I do have a firewall rule (copied from LAN) to allow all traffic through on that VLAN:

    0_1551907133985_Screen Shot 2019-03-07 at 8.12.05 am.png

    And this is the DHCP config - however, I can get a DHCP lease, just not internet access:

    0_1551907158419_Screen Shot 2019-03-07 at 8.12.16 am.png



  • You're only showing half your DHCP config. What do you have listed for DNS servers under Servers?



  • I don't have any DNS servers configured explicitly under DHCP configuration:

    0_1551918227647_Screen Shot 2019-03-07 at 11.17.14 am.png
    0_1551918236209_Screen Shot 2019-03-07 at 11.17.21 am.png

    In this case, the DHCP client on port 17 was pulling 10.0.12.1 as the DHCP server (i.e. pfSense router) and that in turn is using 8.8.8.8 and 8.8.4.4. (And the pfSense router itself definitely has DNS resolution and internet connectivity).



  • Strange. It might be time to start sniffing on the PROXMOX and WAN interfaces to see what's going on with that traffic.


  • Netgate Administrator

    @victorhooi said in Netgate XG-7100 - ix1 (SFP+) - can get DHCP lease but not internet connectivity?:

    I can get a DHCP lease from pfSense - but am unable to get internet connectivity?

    What can you get? can you ping the interface IP? Can you ping any other IP on pfSense itself? Can you ping pfSense's upstream gateway IP?

    You might not have a NAT rule for that interface if outbound NAT has been set to manual.

    Steve



  • Closing this off - for some reason, rebooting the test device worked. (Basically I came back to test and it worked).

    So I can only assume it was either intermittent, or maybe some issue with the DHCP client?


Log in to reply