Proxy IGMP does not working



  • Hello all,

    I'm trying to set up proxy IGMP to pass multicast among two internal network (LAN), bellow my config.

    0_1552057046354_Screen Shot 2019-03-08 at 11.54.48 AM.png

    By default I'm not able to access a multicast stream from another LAN network because the pfsense won't be able to routing this traffic so I'm trying to do it using proxy IGMP bellow my configuration.

    IGMP proxy config
    0_1552057251782_Screen Shot 2019-03-08 at 11.51.50 AM.png

    Allow IP options
    0_1552057612389_Screen Shot 2019-03-08 at 12.06.23 PM.png

    pfSense Version
    0_1552057366736_Screen Shot 2019-03-08 at 11.55.44 AM.png

    igmpproxy -d -vv /var/etc/igmpproxy.conf - output
    0_1552057442008_Screen Shot 2019-03-08 at 11.53.02 AM.png

    Someone has an idea why it does not working?

    Thanks all


  • Netgate Administrator

    What does igmpproxy.conf look like?

    I see no logging at all from 172.20.20.X. And two mentions of the CPP VLAN, did it just add that twice.

    Is that all the output at start up?

    Steve



  • Hi Steve,

    Thanks for answering!

    Maybe I hadn’t to be clear about test I’m doing,

    I’m using http://www.videolan.org/vlc/index.html (VLC) in a windows server 2019 with disabled firewall to generate a stream multicast video in a network segment (LAN) and then I'm trying to access it by other network segment (LAN2) using proxy IGMP, below the step-by-step in case someone wants to test.

    With the client on the same network segment I'm able to access video stream on vlc server by vlc client.

    Server step-by-step

    1. Install VLC on server and client
    2. In the Media menu, choose “Stream”
    3. In the Open Media dialog file tab, click “add” and choose the video file you want to stream and click “Open”
    4. At the bottom, click the “Stream” button
    5. This opens the “Stream Output” dialog showing the source file you have chosen. Click Next to set destination.
    6. In “Destinations”, choose “RTP /MPEG Transport Stream” and click the “Add” button
    7. In the “Address” box, enter the required multicast address (eg 224.0.0.61) and set the port (or leave default at 5004)
    8. In transcoding options, choose the appropriate settings for your video and PC’s codecs. I chose “Video H.264 + MP3 (MP4”.
    9. Once the options are set, click “Save”. Then click Next for “Option Setup” and select “Stream all elementary streams” then click stream.

    Client step-by-step

    1. Install VLC on server and client
    2. Choose Media/Open Network Stream
    3. In address, enter rtp://@224.0.0.61:5004 – choose the correct address and port you entered when setting up the stream. Don’t forget to enter the “@” symbol after “rtp://” and before the multicast ip address!
    4. Click “Play”

    igmpproxy.conf - output
    0_1552324634489_Screen Shot 2019-03-11 at 1.44.33 PM.png

    igmpproxy -d -vv /var/etc/igmpproxy.conf - output
    0_1552324773599_Screen Shot 2019-03-11 at 2.19.09 PM.png
    0_1552324798479_Screen Shot 2019-03-11 at 2.19.24 PM.png


  • Netgate Administrator

    Hmm, you might be hitting this: https://redmine.pfsense.org/issues/9338

    You could try the workaround shown there, assign and enable cpsw0 directly in addition to the VLAN on it.

    Steve



  • Steve,

    igmpproxy.conf
    0_1552338329668_Screen Shot 2019-03-11 at 6.04.22 PM.png

    It hasn't worked.

    I don’t think is that the issue, I already had seen https://redmine.pfsense.org/issues/9338 so considering this I've built a virtual environment without vlan interfaces to test IGMP proxy considering some issue with vlan interface but the result was the same.

    Thanks,



  • @fernandopf I have had no success either. I could be my configuration:

    • Media Server on VLAN 20 (10.2.10.200)
    • Trusted Wired Clients on VLAN 25 (10.2.25.0/24)
    • Trusted Wireless Clients on VLAN 30 (10.2.30.0/24)
    • IGMP snooping enabled on my UniFi switch for VLANs 20, 25 and 30

    IGMP Proxy enabled with

    • Upstream being the media server
    • Downstream being 10.2.25.0/24 and 10.2.30.0/24
    • Firewall rules enabled for IGMP from 10.2.25.0/24, 10.2.30.0/24 and 10.2.20.0/24 to anywhere with "Allow packets with IP options to pass" enabled under advanced options for each IGMP rule

    I have downloaded the latest IGMP proxy binary (dated April 30) from https://pkg.opnsense.org/FreeBSD:11:amd64/snapshots/latest/All/
    Interestingly, the size difference from the latest pfSense 2.4.4-RELEASE-p2 (amd64) release and the snapshot is 130K (snapshot) to 39K (release). This has worked for some but no joy for me.


Log in to reply