Strage behavior my DHCP seems to be working fine but none of the static IPs do



  • I have my dhcp configured like that, it seems to be working but, recently I started acting and besides upgrade to 2.4.4-RELEASE-p2 (amd64) I did not do anything.

    0_1552413666247_Screen Shot 2019-03-12 at 1.56.40 PM.png

    Any static IP outside of range defined here does not work

    1. tested on 2 computers off physical port (windows, mac) e.g 10.201.0.11 or .12 with subnet /20
    2. can't even ping gateway 10.201.0.1
    3. dhcp seem to be working fine, I get address and it works off physical port and wifi (I can browse internet)
    4. since this interface is used on wifi some users started complain that they are unable to connect, they don't get IP address. Old devices that were connected here before work fine, cant replicate.
    5. Logs does not show problem to me, especially dhcp logs except that service may have restart

    Mar 12 12:38:51 dhcpd Server starting service.
    Mar 12 12:38:51 dhcpd Sending on Socket/fallback/fallback-net
    Mar 12 12:38:51 dhcpd Sending on BPF/igb0/00:08:a2:0c:9b:81/192.168.5.0/24
    Mar 12 12:38:51 dhcpd Listening on BPF/igb0/00:08:a2:0c:9b:81/192.168.5.0/24

    1. I tried dhcp reboot
    2. I tried that:

    killall -9 dhcpd

    rm /var/dhcpd/var/run/dhcpd.pid /var/dhcpd/var/run/dhcpdv6.pid

    1. I tried to remove all lease files from /var/dhcpd/var/db/ and reboot
    2. I verifed my rules, basically I allow all traffic to go out, ANY
    3. I have similar interface with the same structrue and addressing but it is 10.202.0.0/20 with the same dhcp range and it works perfectly fine when I do static IP e.g 10.202.0.11/20 why?
    4. I made sure those IP are not in use by pinging them

    Why my static IP does not work, why I cant even ping gateway?

    update: 12) I removed this interface, recreated rules and dhcp settings including rage and static IP still does not work. I have noticed that my iphone after this procedure still keeps old IP so lease was kept.

    1. I just checked routes and sth is not right all networks behind NAT have gateways that points to link#NUMBER but the one I am interested is pointing instead to IP 10.201.0.2 instedad of .1 or link#


  • I removed openVPN server and it started working. Sth must have happened after last upgrade


Log in to reply