Get PFSense through a Netgear d2200d modem/router



  • I am trying to get our pfsense box (XG-7100 running 2.4.4) through a Frontier DSL Netgear d2200d modem/router in PPPoE mode. The modem has 2 public sides. The WAN has a public IP 184.xxx.xx.83 and the LAN side has a Public IP 184.xxx.xx.193 DG 184.xxx.xx.194. I called the ISP to verify these IP's are correct. I add the LAN public IP scheme to the WAN on the pfsense, and get no outside internet. I had the same experience with a TDS fiber modem, and we had to put it in bridge mode to get it to work correctly. So i tried bridge modem with the DSL modem with the same IP LAN scheme and nothing worked. So i put the pfsense WAN on DHCP just to see if i could get an IP, i did, 512 of them. It gave me a 50.104.xx.xx /23. i figured this wasn't right so i called the ISP can asked them about it and they wasn't sure where i was getting the 50.104 from and i must run the modem in PPPoE mode in order to use the public IP we pay for, not bridge mode. So my question is, has anybody used one of these modems/router in PPPoE mode with a pfsense box?



  • I would first verify that the ISP provided modem/router is actually working correctly by connecting a PC or laptop to the router's "LAN" side and give the PC that 184.xxx.xx.193 IP address, set the default gateway and then verify the subnet mask is correct. With that setup, see if you can ping 8.8.8.8, for example. Also verify you can ping the default gateway IP they gave you. If that does not work, then something is wrong on the ISP's side of things.

    If that setup works, then you need to go back and redo your pfSense setup. Don't overlook the obvious that your LAN IP network in pfSense must be a different subnet from the WAN side of pfSense. We've seen folks make that mistake several times recently.



  • Got it working. Come to find out the Public LAN on the modem was not enabled or setup. Once i did that, everything it worked.


Log in to reply