Cap. port. on total local configuration.



  • Hello,

    This is my configuration :

    version RC1

    WAN = 192.168.1/24
    LAN = 192.168.0/24
    WLAN = 192.168.2/24 (=OPT1)

    Fix IP for all psfense interfaces = .1

    Cap. port. is active for WLAN interface.

    So, I am working without a real internet connection, so without DNS servers.

    CAp. port. is working fine with the WiFi connection if I call in a webbrowser the adress 192.168.1.1 (with is the local WAN interface, so I receive a login window for the pfsense login).

    Problem is that the cap. port. login isn't comming up if f.e. I use http://www.doesnmatherwithadress.com
    I know WLANIP:8000 is an option but I what it having working also for those users how don't know anything about the configuration/network.

    Someone an idee ?
    Thanks.



  • You have to use the dns-forwarder of the pfsense for the wireless clients. Otherwise it can't redirect to the captive portal page. Set up your LAN DNS server at system>general and assign the wireless clients the pfsense wlan IP (done by default). Also uncheck "block private IP ranges" at interfaces>wan.


Log in to reply