kernal modules loading problems



  • I get the following module related errors during startup.

    1. starting device manager (devd) kldload can't load ums: no such file
      there is no ums module under /boot/kernel

    2. module_register_init: MOD_LOAD (vesa, 0xffffffff81209800, 0) error 19
      ** interestingly, kldload vesa shows no module, and there is no vesa module under /boot/kernel


  • Netgate Administrator

    What did you actually add to loader.conf(.local)?

    What hardware are you loading it on?

    Steve



  • above errors are without anything added.

    1. is because usb mouse is plugged in. If i unplug the mouse, i don't get this error.

    2. appears on both the old live system and newer test system.
      both systems are the Chinese J1900 4x LAN i.e. Qotom, etc.

    tried adding,
    #i915kms_load="YES"
    #drm.i915.enable_unsupported=1
    which i read in one post, but that is what caused me to loose access i.e. booted and froze without lan access

    tried adding,
    #kern.vty=sc

    but then the rgb monitor attached to the unit stops responding once that is loaded.


  • Netgate Administrator

    Ok. See my reply on your other thread for disabling that.

    Steve


Log in to reply