Gateway do Link Secundário (WAN2) Fica Sempre Offline - Failover de Links Não Funciona



  • Olá pessoal,

    Estou com problemas no pfSense versão 2.4.4-RELEASE-p1 onde tenho 2 links de Internet, sendo que o link primário o gateway fica online e o link secundário sobe as configurações corretamente na interface de rede inclusive com o gateway, mas ele fica offline.

    A finalidade para esse pfSense foi também aproveitar o recurso de failover, caso o link principal na WAN1 fique inoperante o link secundário na WAN2 assuma de forma automática.

    O Grupo de gateway está criado para fazer o failover mas não está funcionado acredito eu por que o gateway da WAN2 aparece offline conforme os prints abaixo postados.

    0_1552656242307_Grupo-Gateway-Failover.PNG

    0_1552657476563_Monitora-Gateway-WANs.PNG

    Portanto da maneira que se encontra caso o link principal caia o secundário não assume automaticamente.

    Para funcionar o secundário eu tenho que ir até a opção de default gateway e trocar para o gateway da interface WAN2 conforme print abaixo.

    0_1552657835289_Default-Gateway-WAN2.PNG

    Alguém já passou por esse problema e conseguiu identificar qual a solução a ser aplicada para que o grupo de gateways do failover funcione de forma automática e totalmente transparente?

    Sugestões são bem vindas.

    Obrigado.

    Atenciosamente.

    César Moura



  • Olá, você setou o monitor IP para um destino que sua WAN2_DHCP consiga se comunicar?



  • Olá leo_pfsense,

    Sim no monitor IP está setado na WAN1 o servidor de DNS do Google 8.8.8.8 e na WAN2 o servidor de DNS do Google 8.8.4.4

    Inclusive já coloquei outros IP no monitor da WAN2 (1.1.1.1 / 9.9.9.9) e a WAN2 no dpinger continua offline.

    Atenciosamente.

    César Moura



  • Essa sua WAN2, fora do grupo de gateway, fica online?



  • Olá leo_pfsense,

    Não tinha reparado e feito ainda esse teste!!!

    Fiz agora tirando a WAN2 do grupo de gateway, e a mesma continua pelo monitoramento do dpinger como offline.

    O que poderia ser? Você tem alguma sugestão para tentar resolver o problema apresentado?

    Por enquanto muito obrigado pela ajuda prestada leo_pfsense.

    Atenciosamente.

    César Moura



  • Olá leo_pfsense,

    Descobri por que a WAN2 não ficava online e agora o gateway secundário está ativo corretamente e o failover também está funcionando corretamente!!!

    O detalhe era setar o Data Payload da WAN2 de 0 (default) para 1. Achei essa informação lendo uma documentação no fórum em https://forum.netgate.com/topic/98407/dica-gateway-monitoring-daemon-não-funcionando-no-pfsense-2-3-dpinger

    Obrigado leo_pfsense pela ajuda prestada.

    Atenciosamente.

    César Moura



  • Oi @acamoura ! fico feliz que você tenha conseguido resolver a questão. Interessante a informação sobre o payload, não conhecia esta opção, deve ser em razão de alguma particularidade do seu cenário, do provedor talvez.

    Abraços e boa semana!



  • @acamoura obrigado pelo seu post cara, estava com esse problema há mais de um mês e também consegui resolver.

    Abraços



  • Olá @bcl,

    Estamos presentes aqui no fórum para todos nós nos ajudarmos.

    Abraço.

    Atenciosamente.

    César Moura


Log in to reply