• I added the i915 drives to loader.conf.local and now my system hangs so i can't get in to prevent it from loading.

    Have tried booting to live cd shell and mount but it doesn't work.
    geom disk list = ada0

    mount: /dev/ada0: Invalid argument
    mount: -t /dev/ada0 /tmp/tst : Invalid argument
    mount: -t ups /dev/ada0 /tmp/tst : Invalid argument
    mount: -t UPS /dev/ada0 /tmp/tst : operation not supported by device
    mount: -t zfs /dev/ada0 /tmp/tst : Invalid argument
    mount: -t ZFS /dev/ada0 /tmp/tst : operation not supported by device

    how can i prevent loader.conf.local from loading or get access to edit out the driver?

    would be helpful if there was some kind of rescue guide...

  • Netgate Administrator

    Are you running ZFS?

    Otherwise boot to single user mode then run:
    mount -a -t ufs
    You might have to fsck it first.

    Then edit loader.conf.local.


  • @stephenw10 i used ufs / gpt settings, but booting to either single or multi seems to load loader.conf.local

  • LAYER 8 Rebel Alliance

    Boot your pfSense installation CD or USB thumb, hit 2 Single User mode
    mount -a -t ufs /dev/da0s1 /tmp


  • Netgate Administrator

    You might be able to prevent it loading by running at the loader prompt:
    set hint.i915kms.0.disabled=1

    Assuming you're talking about the graphics driver.