Squid (transparent) -> HAVP



  • So I have squid setup in transparent proxy mode, and have it's 'upstream proxy' set to 127.0.0.1:3129.  I have HAVP listening on port 3129.  it seems to work, ie: /havp/access.log has entries….however, if I go to the eicar antivirus test page I can download the test virus fine and I don't see an entry in the access log for that particular file.

    So, what gives?

    edit: okay, I just tried downloading something else and got an error message stating 'Not enough free space on server'.  I have 80GB Hard disk and 2GB RAM, so I think my config is wrong somewhere.



    • Disable Upstream proxy option
    • Add squid custom option: cache_peer 127.0.0.1 parent 3129 7 no-query

    squid GUI can't make no-query option



  • Dvserg. Does your reply mean that HAVP for pfsense can work with Squid in transparent mode now? I was under the impression that you were working on that.



  • @lordarcane:

    Dvserg. Does your reply mean that HAVP for pfsense can work with Squid in transparent mode now? I was under the impression that you were working on that.

    Possible test this ? (Squid transparent => havp )
    In non-tranpsarent mode this work.


Log in to reply