Need SIPproxd help



  • Hi,

    I need help with SIPproxd I have an adapter that if I hook it up to my internet directly with no firewall I will have no issues at all audio both ways. If I hook it behind my PFsence firewall I do not get audio back in it is the typycal one way audio issues of SIP. I installed the SIPproxd plugin and I have tried to configure all of the settings in my adapter in SIPproxd and the firewall but I cannot get two way audio.
    I attached some screen shots of my configs the client is back to the settings that worked directly connected to the internet I have tried to replace the SIP Proxy and Outbound Proxy with 192.168.78.1 which is the IP of my PFsense but I had no luck I have tried many diffrent settings that did not work as of right now I am just guessing and waisting my own time.

    Thanks








  • Got it working my first mistake was searching for sipproxd it is spelled SIProxd…
    The second issue is I had firewall rules in place to open ports that was not necessary do not apply firewall or NAT rules even though on the SIProxd page says to make sure the firewall was not bolcking ports.
    The third issue I found was that the min and max RTP port range was not showing up in the siproxd.conf file located at /usr/local/etc/siproxd.conf with the fields being blank I had to enter the ports into the boxes to get the entry to show up in the conf file.
    And the last hurdle was to get my hardware client to connect I found siproxd is not transparent I needed to specify an outbound proxy on my hardware client.







Log in to reply