Ethernet NIC not working in PfSense

  • I am new to PfSense and FreeBSD and have very little understanding of the operating system and how they work. When I install it only detects the onboard NIC that I am using for the WAN connection. I have another NIC installed into the PCI port (Sun Quad Port GbE PCIe 2.0) I'm using a Dell Optiplex 3010 with the latest BIOS. Whenever I run pciconfig -lv I get one adapter (re0) and the rest say none. The ethernet adapter works perfectly on Linux and the virtual machine that I tested PfSense on. Any help would be appreciated. I have tried nearly everything I could find on the internet, and none of them have worked.

    I don't know if this is related, but when I try to boot in UEFI mode it pauses after a few lines and doesn't progress past there.

  • I added 2 NICs to my firewall and never had a problem. They just work. You could try a live Linux disc or USB stick, to see if it sees both NICs. However, I suspect a hardware issue.

  • Sounds like a driver issue to me. You will most likely have to locate BSD drivers for that card and load them manually. Otherwise, unfortunately, you may end up having to replace the card with something that has native driver support.

  • @marvosa Thank you for your help. I found a driver that should work with the card, but I don't know how to to install it into PfSense. Driver link

  • Loading the latest version of Freenas updated the BIOS of my 10Gb NIC which allowed PfSense to see my NIC. You may have a firmware issue. Try putting FreeNas on a USB stick and see if this works for you.

  • Netgate Administrator

    Nice tip, be good to know if that fixes it.

    Otherwise I'd check the PCI IDs from pciconf -lv. Also look at the boot log for driver attach errors.


Log in to reply