Altq support on i211 LAN interface



  • Hi all,
    I am new to pfSense and have installed it on my own a few weeks ago. It all works fine, really glad I made the switch from an off the shelf consumer grade firewall. This is a fabulous solution.

    I have 2 NICs running on i211. The lan interface is not bridged (assuming I have looked at the right place). My 2 interfaces are showing as igb interfaces in pfSense.

    pfSense version is latest release 2.4.4.

    For unknown reason, i cannot setup traffic shapping but only basic limiters. When i try, i get the following message underneath the LAN input textbox (WAN doesn’t have it): « This firewall does not have any LAN-type interfaces assigned that are capable of using ALTQ traffic shaping ».

    I’ve searched in the forum and found a couple of dated references to this problem, where it shows that this had been fixed but obviously, something doesn’t work for me. I have yet to find a clear resolution path.

    Any help would be appreciated.
    Thank you


  • Rebel Alliance Developer Netgate

    Did you maybe accidentally set a gateway on the interface config page for those? For example on Interfaces > LAN you shouldn't have a gateway defined/chosen on that page.

    igb supports ALTQ, so it may just be how you have them setup.



  • @jimp i don’t think so. In the section named "Static IPv4 Configuration", the upstream gateway is set to None. Am I looking at the right setting?

    Thank you



  • @jimp although i have no gateway specified, i wondered whether the IPV6 configuration type i have on the LAN interface, may be the culprit. I switched it from DHCP6 to None and... bingo!! The traffic shaping error message is gone.

    I don’t understand much ipv6 and i remembered having changed the default setting wthout really knowning what i was doing. but since i am not really using ipv6 on my network, i didn’t care too much. That was apparently a mistake. Not 100% sure setting it to none is the right thing to do but at least, i know that influences the shapping.


Log in to reply