DNS Resolver Issues...What's going on here?



  • I'm currently using DNS Resolver localhost and have added cloudflare and google

    DNS.jpg

    Web pages are slow to load and many times I get stuck even refreshing a webpage.

    DNS issues.jpg

    I seem to have some setting off or messed up. Using DNS Benchmark only sees local. I've turned off pfblockerng thinking that may have something to do with it, but no changes.

    DNS Benchmark.jpg

    I have DNSSEC, DNS Query Forwarding, DHCP Registration, and Static DHCP all checked. Also, Prefetch Support, Prefetch DNS Key Support, Harden DNSSEC Data, and Serve Expired in Advanced Settings.

    What am I doing wrong here?



  • Hello,

    Did you try to use ISP DNS Servers on the top? In my pfsense, DHCP Registration, Static DHCP. Prefetch Support, Prefetch DNS Key Supportare uncheked. In the past I have enabled DHCP Registration and Static DHCP, but after a while my DNS resolvee began to restart by itself, then I disabled it.



  • Do you have IPv6 enabled?



  • I suggest delete other DNS server ip addresses and use only ISP DNS Server for testing.



  • Haha I was replying to @ARAMP1...

    Disable DNSSEC and see if it works. I've had problems in the past with some public DNS and their DNSSEC. Are you sure your client is using pfsense for DNS?



  • @emammadov said in DNS Resolver Issues...What's going on here?:

    Hello,

    Did you try to use ISP DNS Servers on the top? In my pfsense, DHCP Registration, Static DHCP. Prefetch Support, Prefetch DNS Key Supportare uncheked. In the past I have enabled DHCP Registration and Static DHCP, but after a while my DNS resolvee began to restart by itself, then I disabled it.

    Yes. As a matter of fact, I was using my ISP's DNS server for a little while and thought my problems were coming from that, so I turned it off. Same issues. I'll probably play around with some of these settings to see if that doesn't help. Thanks.

    @KOM said in DNS Resolver Issues...What's going on here?:

    Do you have IPv6 enabled?

    Yes.

    @KOM said in DNS Resolver Issues...What's going on here?:

    Disable DNSSEC and see if it works. I've had problems in the past with some public DNS and their DNSSEC. Are you sure your client is using pfsense for DNS?

    I'll try that. Thanks. Yes, I show that I'm using pfsense for DNS.
    Connection.jpg



  • You could also try System - Advanced - Networking - Prefer IPv4 over IPv6. Check it and see if that makes a difference.



  • @KOM said in DNS Resolver Issues...What's going on here?:

    You could also try System - Advanced - Networking - Prefer IPv4 over IPv6. Check it and see if that makes a difference.

    I'm not sure how it got unchecked, but it was. This may have been the issue. It seems faster already. Thanks.



  • Leonardo Acropolis: "I am... a geniussss."

    DnJ7Sh5XcAApRTb.jpg



  • i had this issue as well.

    i ended unchecking allow dns server list to be overridden by dhcp

    checking. do not use dns forwarder/ dns resolver as a dns server.

    then under services > resolver. i turned OFF DNSSEC support.

    no issues ever since


Log in to reply