Assign Subnets from IPv6 /60 Delegated Prefix to Two Interfaces



  • I am receiving a /60 delegated prefix and trying to assign subnets from that to two interfaces (one is a VLAN) using "Track Interface" set to the WAN interface and different Net IDs.

    I had it working with one interface and /64 delegated prefix. Now when I request a /60 prefix, The LAN and VLAN interfaces each get the right IP with the NetID as part of the IPv6 address along with the delegated prefix, but they are both using the same /60 subnet.

    Now clients that used to work aren't receiving IPs anymore, and DHCP logs are complaining that multiple interfaces are on the same subnet. When I look at interface status page, sure enough they both pulled /60 as the subnet mask and are on the same subnet.

    I was expecting each interface to pull a /64 by default rather than set themselves as a /60. Any pointers to help me understand what I have done wrong here would be much appreciated.

    Cheers.



  • @chrisarm

    Have you set IPv6 Prefix ID do a different value for each interface or VLAN? With a /60, you choices are within the range of 0 - f.



  • Yeah, I had the PrefixID set but was calling it a NetID. Sorry for the confusion. Got IPv6 working by changing the LAN DHCPv6 Server + RA setting called "Delegation Prefix Size" to a 64 on the DHCPv6 Server + RA settings for the LAN interface and unchecking "Use DHCPv6 Server Settings" in the DNS Configuration at the bottom. Still not sure why that fixed it. But got a 10/10 with no warnings at https://test-ipv6.com.

    Settings from here were helpful getting it to the point I had it before:
    https://forum.netgate.com/post/619372

    Now time to make sure I have policies set properly...Routable IPs in an internal network are a new level of fun. The VPN issue in particular.
    https://docs.netgate.com/pfsense/en/latest/vpn/ipv6-and-vpns.html

    Cheers.


Log in to reply