Dual WAN - not failing back to primary



  • Hello All,

    I'm having an issue with 2.4.4-RELEASE-p1, and can't seem to find a solution. My primary Internet connection is a 1 Gbps symmetrical GPON circuit, and my backup is a 10 Mbps HFC circuit. Both circuits are dual-stack. The primary circuit is monitored for IPv4, and unmonitored for IPv6. My backup circuit is monitored for both IPv4 & IPv6.

    The GPON circuit uses PPPoE. The backup circuit terminates to a cable modem, and is configured with an RFC1918 /30 facing the firewall.

    Here's what's happening - when my primary circuit loses PPPoE during an outage, the firewall fails to the backup circuit without any issues. When PPPoE is re-established, I have to turn the backup interface down in the firewall or physically disconnect/reconnect the cable to revert traffic back to the primary.

    Any suggestions? I'm new to pfsense, but well versed in routing & switching. I'm betting this is something really simple that I'm missing. Assistance would be appreciated!

    Thanks!

    Ben



  • My first suggestion would be to upgrade to 2.4.4-p2, but I don't think that alone would solve your problem.

    I would set this up with a default gateway group using the 1Gbit gateway as tier 1 and the 10Mbit gateway as tier 2. This would ensure new connections use the prioritized 1Gbit gateway if it's up.

    As pfSense is stateful it won't drop connections unless it has to, so existing connections won't jump over to the faster line as soon as it's back up by default.
    If this is your wish, you should enable the setting on System->Advanced->Networking named Reset all states I guess. I have never tried that setting myself.

    **Reset All States**
    Reset all states if WAN IP Address changes This option resets all states when a WAN IP Address changes instead of only states associated with the previous IP Address.
    

    You should look at System->Routing->Gateways to see if the default gateway does switch back to tier 1 when the 1Gbit gateway comes back up.


Log in to reply