Dual WAN Not Load Balancing



  • Hello all,

    I am currently running pfsense 2.4.4-RELEASE-p2 with two WAN connections from two different ISPs. The gateways on each of these individual WAN connections are functioning properly and I have created a gateway group for the two connections. I have also set the default LAN firewall rule to use the newly created gateway group. If I set one of the WAN connections to tier 1 and the other to tier 2, and take out the primary connection, the system properly fails over to WAN 2. However, if I keep both WAN connections on Tier 1, they do not load balance. It is my understanding that as long as both connections are on the same tier, by default the system should implement a round robin load balance. However, no traffic seems to be sent through the second WAN connection. I currently have sticky connections enabled, but I have tried it without sticky connections as well and still no traffic passes through the second WAN connection. According to my status indicators all of the gateways are online and I am able to ping Google's DNS server from each of the individual WAN connections. So I am unsure why I cannot get the system to load balance.



  • I have not personally set up load balancing although, from the video's I've watched on the subject, I believe in addition to setting both gateways to the same tier, I believe you also have to give each gateway equal weight when in the group.



  • I have tried that. I have both set to the same weight (I even tried different weights). Neither seem to have an affect on what is happening.



  • Hmm, I wasn't aware that you can do both failover and load balancing at the same time.



  • @pfrickroll From my understanding if you put each WAN on different tiers in the gateway group it will failover to the lower tier if it needs to. If I put WAN1 on tier 1 and WAN2 on tier 2 and cut the connection to WAN1 it will automatically switch to WAN2 and function properly. This is how I know there is nothing wrong with the actual WAN2 connection. However, if I put them on the same tier they should load balance, and it does not seem to be doing that.



  • In Gateway, I created two connections in Gatewey Groups. I created a MultiWan group for two wan. I installed Tier 1 triggers, put Packet loss or High latency, Default gateway v4 set MultiWan in rules - lan / rule set my MultiWan. In General Setup registered dns on both wan. But does not work with pfsens ping ip, dns do not respond,
    On the local computer, too, dns does not ping and ip, for example, 8.8.8.8 does not respond. I put in default getawey v4 instead of Multiwan for example wan2 everything works, you switch to multiwan by default it works but on WAN2 everything remains exactly in parentheses default, you reboot again the same fake.


Log in to reply