4G LTE Modem Routing Questions



  • Hello,

    I have spun up an old pfSense box running 2.4.2 in a new location.

    I am using a Netgear AC800S Aircard on Optus 4g in Australia. Connected to the pfSense machine via UBS.

    pfSense is on 192.168.1.2

    All is well in pfSense recognising the USB device and giving it an interface at ue0. I have created a new assignment called MOBILE on this interface with IPv4 & 6 as DHCP.

    In System > Routing changed the newly created GW's to default for IPv4 & IPv6.

    The IP for MOBILE_DHCP is showing as 10.201.69.1 I'm not sure what IP this is from the network carrier.

    On the dashboard I am showing as green for the MOBILE interface and an IP of 10.201.69.94.

    All of this seems to indicate that the AC800S via USB is working and the IP Passthrough working correctly.

    But no internet access from a machine connected to the LAN side.

    In the logs I am getting the following...

    arpresolve: can't allocate llinfo for 10.201.69.1 on ue0

    I'm sure this is a routing / firewall issue with pfSense. Really stuck as I'm at the far end of my knowledge.

    Can anyone suggest a course of action?



  • @simpic
    Hey
    https://www.freebsd.org/cgi/man.cgi?query=arp&apropos=0&sektion=4&manpath=FreeBSD+11.2-RELEASE&arch=default&format=html

    arpresolve: can't allocate llinfo for %d.%d.%d.%d The route for the ref-
    erenced host points to a device upon which ARP is required, but ARP was
    unable to allocate a routing table entry in which to store the host's MAC
    address. This usually points to a misconfigured routing table. It can
    also occur if the kernel cannot allocate memory.


  • Netgate Administrator

    What subnet mask are you being given on ue0 when it's connected? Check status > interfaces.

    Steve



  • @stephenw10 got this...

    c018e346-5a4b-4086-9d06-a5dfbc827844-image.png


  • Netgate Administrator

    Ok, there you go. The gateway is outside the WAN subnet, which is /32, so it cannot ARP for it.

    Try editing the gateway and checking 'Use non-local gateway'.

    Steve



  • Great, thanks, that worked. Would not have thought of that for my life!

    GW up and online now. pfSense can connect to the internet as I have just upgraded to 2.4.4

    No browser traffic though. Could be a DNS issue. I will check that.

    d608c164-3300-4ee9-b4e4-bf22d77fa0d2-image.png


  • Netgate Administrator

    Nice!

    Must have some DNS since the upgrade happened. Maybe you are policy routing all traffic from the clients so they can't hit pfSense for DNS?

    Steve



  • Works now.

    I applied the MOBILE GW to the DNS servers in System / General and checked the Disable DNS Forwarder tickbox.

    All working now.

    Thank you for your help.


Log in to reply