SolarWinds Anywhere remote agent does not connect.



  • Dear, I'm new to pfsense. I configured my as a transparent proxy using squidguard. However my anywhere agent does not connect. I was releasing some IP ranges by ByPass. It works. But I realize there are many tracks. I can not identify all of them. And I do not understand why you're blocking the ips by the squidguard. Could someone help me with this situation?



  • Provide a LOT more detail if you want help. Is the connection hanging/timing out, or is there an error message? Squid is not very good at caching secure content, so unless you require squidguard for URL-filtering then I would consider getting rid of squid and see if your problem disappears.



  • Hello, I need to filter url. Then I realized that the destination addresses are from AWS. But I can not see where it shows the locks. I have access to tail -f /var/squid/logs/access.log
    But I do not understand why IPS blocking happens. My firewall did not have any blocking rules. I used the Bypass Proxy for These Destination IPs: And I fished a few ips for the station. When put in, it worked for a while. Sorry, I'm still in PFSense. If you can help me with the path where I view the lock. I have access via Putty.



  • Squid doesn't block anything. It's just a proxy. If you want to see what's blocked, check either the System Firewall log, or the Squidguard log. However, unless you have created an ACL for the Solarwinds client PC and linked it to a blacklist, then your problem is likely not squidguard. I don't know anything about this remote agent. Which network ports does it use? If not tcp80,443 then squid would not even be involved.

    If you disable squid and let the client go directly out, does the agent work?



  • 515/5000
    It does work, it works on 443. When I put an IP of the station to go outside Squid. By Bypass Proxy for These Source IPs. It works on time! I already checked the SquidGuard rules. I made the releases of the domains as per the manual: https://support.solarwindsmsp.com/kb/solarwinds_n-central/Take-Control-Take-Control-MSP-Anywhere-Firewall-Ports-and-Domain
    I'm not sure how to deal with this problem. So my agents are all offline. Only released customers that are running!



  • 515/5000

    Sorry, what does this refer to?

    According to that page you linked, the agent can work in two modes. The first uses tcp3377, the second uses standard web ports. Have you tried with the first method? Have you checked any of the logs I mentioned? Have you checked Squid's log?


Log in to reply