package Install issues - solved?



  • In an attempt to test my Realtek NIC stability I have tried to install the iperf package from the package manager. Under available packages is a quite a bit older package for 2.0.5.5_3. regardless it is good enough for my purposes, so I attempted to install it via the GUI, and got an error.

    pfSense-pkg-iperf installation failed!
    

    searching the forum, I saw advice that you could install v3 via ssh command line (I didn't know there were any packages not in the package manager!) so I tried that. (pkg install iperf3) I got another sort of error

    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    The following 1 package(s) will be affected (of 0 checked):
    New packages to be INSTALLED:
            iperf3: 3.6 [pfSense]
    Number of packages to be installed: 1
    104 KiB to be downloaded.
    Proceed with this action? [y/N]: Y
    [1/1] Fetching iperf3-3.6.txz: 100%  103 KiB 105.9kB/s    00:01
    pkg: cached package iperf3-3.6: size mismatch, fetching from remote
    Fetching iperf3-3.6.txz: 100%  103 KiB 105.9kB/s    00:01
    pkg: cached package iperf3-3.6: size mismatch, cannot continue
    

    at this point I am wondering if something is wrong with my packaging, so I followed the advice in the documentation on fixing a broken pkg database, and that seemed to go bad as well ...

    /root: /bin/mkdir -p /var/db/pkg/ /root/var/db/pkg/
    /root: /usr/sbin/pkg-static update -f
    /usr/sbin/pkg-static: Command not found.
    /root: /usr/sbin/pkg-static install -yf pkg pfSense pfSense-kernel-pfSense
    /usr/sbin/pkg-static: Command not found.
    /root: /etc/rc.php_ini_setup
    

    afterwards I tried to install another simple package (cron)

    pfSense-pkg-Cron installation failed!
    

    Strangely, I was able to upgrade an existing package

    pfSense-pkg-acme reinstallation successfully completed.
    

    and

    pfSense-pkg-openvpn-client-export reinstallation successfully completed.
    

    not knowing really how to handle this I reverted to my IT crowd training and turned it off and on again.

    this time

    pfSense-pkg-iperf installation successfully completed.
    

    and since why not I tried the iperf3 package and this time..

    1/1] Fetching iperf3-3.6.txz: 100%  104 KiB 106.6kB/s    00:01
    Checking integrity... done (0 conflicting)
    [1/1] Installing iperf3-3.6...
    [1/1] Extracting iperf3-3.6: 100%
    

    so, other than to add my experience for the next person .. any ideas why I could reinstall existing packages, but not install new ones, and a simple reboot fixed it?


Log in to reply