pfSense 2.4.4-RELEASE-p2 with Huawei ME909s-120 modem



  • Hello

    I try to configure the 4G/LTE Modem on my pfSense 2.4.4-p2.
    The internet connection look like OK, but i receive a wrong gateway from my provider.

    Dashboard:
    wan.png

    Here the Modem:
    Manufacturer: Huawei Technologies Co., Ltd.
    Model: ME909s-120
    Revision: 11.617.01.00.00
    IMEI: 867377025534920
    +GCAP: +CGSM,+DS,+ES

    On the Gateway it is offline
    aef20c5f-d1db-46ea-b6d0-35e7ddc15046-image.png

    I tried to put the Settings on the file "serviceproviders.xml" on "/usr/local/share/mobile-broadband-provider-info"
    with this entries:

    0575f1bf-9593-4afa-89e2-e79d97fca135-image.png

    This is the Setting, who i received from SALT Switzerland:

    0763fae9-8a1d-49a3-a426-0c6f1999759c-image.png

    Here the Settings of the LTE-Modem:
    b8820ae4-e256-4e3a-b64e-31fcaa0447bb-image.png

    Can someone help me to check if the settings on the file "serviceproviders.xml" are correct ????

    Many thanks

    MICHELE



  • Sorry

    I forgot to put this one:

    955affbd-8df8-42b6-a47b-1a632363ac45-image.png

    Thanks

    Michele


  • Netgate Administrator

    Looks correct except that they are giving you an invalid subnet mask. To work around it edit the ppp gateway and set in the advanced section: Use non-local gateway.

    Steve



  • Hello

    But the pfsense get the same subnetmask and gateway still if use a other SIM-Card provider.

    I tested it with SALT(ex.ORANGE) and SUNRISE at switzerland.

    My Huawei ME909s-120 use the Firmware 11.617.01.00.00, can you tell me where i can download the
    newst Firmware 11.617.15.00.00

    I never find a link to download this firmware, i found only a PDF with the release note from the ME909s-120_WIN_11.617.15.00.00

    Thanks



  • @zhcip

    Can you explain where to put your setting ?

    I put this to the file: /usr/local/share/mobile-broadband-provider-info/serviceproviders.xml

        **<provider>
                <name>Salt Internet</name>
                <gsm>
                        <network-id mcc="228" mnc="03"/>
                        <apn value="internet">
                                <plan type="postpaid"/>
                                <usage type="default,supl"/>
                                <name>Internet Everywhere - SaltSurf</name>
                                <authentication method="pap"/>
                                <dns>213.55.192.52</dns>
                                <dns>213.55.193.48</dns>
                        </apn>
                </gsm>
        </provider>**
    

    Thanks
    ZHCIP


  • Netgate Administrator

    Mmm, in fact it may not be required as it's a PPP link. I was thrown by your mentioning of DHCP.

    With a point to point link the traffic should reach the gateway even outside it's subnet.

    You may just need to set a different monitoring IP. The gateway might not respond to ping.

    Edit the PPP gateway in System > Routing > Gateways tab. Set, for example, 8.8.8.8 as the 'Monitor IP'.

    Steve


Log in to reply