Help with PCIe network card issues



  • Hello all,

    So, the high level overview is that, from my testing, I feel as though the issue with my card is probably a uefi setting or firmware issue that I'm just not getting, and wanted to see if people that were smarter than me could help.

    This post is long: TL;DR (summary) at the bottom.

    Backstory

    I've been running pfsense happily on my asrock b450m-hdv am4 computer with a second gen ryzen 5 processor for a couple of months now, with no issues. I've been using a single port intel nic (pro 1000?) in my x1 pcie slot for a while now, and it's been working fantastically. Decided to get a new nic that is an intel pro 1000 pt dual port server adapter. It's an x4 pcie nic, so I decided to put it in the x16 slot. However, in testing, it wasn't working. This is where my testing comes in.

    Other PC (Old PC)

    During testing, I used another PC to test hardware with. This pc is an old amd based pc from around 2013 (can't tell you much about the hardware). I installed pfsense 2.4.(4?) on it as well as reinstalling pfsense onto my new box. Both of them have pfsense installed to a spinning SATA hard disk.

    Testing New NIC in Old PC

    The new dual port NIC worked in my old pc. In fact, even an old PCI (no e) NIC worked as well. Dang, pfsense is good with hardware!

    Updating Firmware

    I noticed the firmware on my motherboard was stock(1.1). Using asrock's instant flash tool, I got it up to the latest version (1.7) in incremental steps.

    It had no effect.

    Testing Single Port Intel NIC (x1 card) in x16 Slot on New PC

    It wasn't working as well. I wondered if there was some sort of physical damage to the port...
    Which brings me to the next test:

    Testing graphics card in x16 slot on new pc

    Testing a graphics card in the x16 slot worked! Seems odd that two different intel NICs weren't working in the x16 slot, but a graphics card did. Is there a setting I was missing?

    Fiddling with the UEFI

    I don't know how many different settings I tried changing, but it seemed like a lot of them. Maybe there's a really obvious one I'm not thinking of?

    Misc observations

    Some other things I noticed:

    When testing the dual port intel NIC in the old PC, the activity lights on the card were blinking.
    When testing in the new build, both NICs weren't blinking when in the x16 slot.

    I was also plugging both NICs into a switch when testing. The switch has two link
    lights per port. When the connection is negotiated to 1000Mbps, both lights blink,
    and when it's 100Mbps, only one light blinks. I double checked that the cable was an 8pin cat 5e cable. But for some reason, when the NICs were in the x16 slot, it showed activity lights on the switch as being a 100mbps connection. I found that a bit odd, since pciconf -lv wasn't even showing the NICs.

    Summary:

    Firmware on my board was updated to the latest version,
    Single port NIC worked fine in x1 pcie slot, but not in x16 slot
    Dual port NIC didn't work in x16 slot (couldn't test in x1 slot...don't have the equipment for it)
    Dual port NIC didn't show up in pciconf -lv
    Dual port NIC worked in another computer running the same version of pfsense (2.4.4)
    Graphics card worked in the x16 slot (so it seems like it's not a damaged slot).
    Tinkered with several different uefi settings, but I may be missing something, or firmware may not be working properly.
    Also made some observations with switch link lights.

    Sorry for the novel, any advice would be appreciated

    Edit: Also, I realize this is almost guaranteed not to be a pfsense issue, but was just curious if anyone here knows of similar scenarios or issues and can point me in the right direction.

    Second Edit: I totally forgot that the processor in the board isn't a second gen ryzen, it's an athlon 200ge.



  • Boot a live Linux system with the NIC in the x16 slot. If Linux detects it take it to the FreeBSD developers.

    If Linux doesn't detect the NIC it's quite likely that ASRock deliberately limited the x16 slot to graphic cards in the BIOS, in that case have a talk with them.



  • @Grimson Thanks for the reply Grimson. I forgot to mention that I had used an ubuntu live boot and ran lspci with no results...so I'm almost positive it's a lower level issue than the bsd kernel. Thanks for the advice though. If I get any additional information from asrock, I'll post it here.


Log in to reply