pfSense on VM - Internet not working



  • Hello. I rent a dedicated host, my provider gave me one static IP. I created a pfSense virtual machine on Hyper-V, created two virtual switches (WAN and LAN). The WAN settings are completely identical to the physical adapter with a static IP. Static data for WAN (IP, gateway, netmask) is also use in webGUI pfSense (interfaces - WAN - static ipv4). As soon as I configure statical ipv4, the Internet down on the pfSense VM. Therefore, all other virtual machines without access to the global network ... When WAN DHCP is enabled, everything works fine. Please tell me what could be the problem. Is this an IP address conflict? How can I make a local network of my VMs while having access to the global Internet? NAT works, but as I wrote above when configuring a static Internet IP on pfSense VM disappears. I am new to IT, and for me at the moment it is quite difficult to understand the process of building a network ... Thanks you!



  • Ensure that the WAN gateway IP is within the WAN subnet.



  • Yes, it is on the same subnet:
    176.170.120.1 - gateway;
    176.170.120.150 - ip.


  • Netgate Administrator

    Is that the same IP address you are given via DHCP? Why are you trying to use a static IP?

    Do you see any errors in the system log?

    Steve



  • @stephenw10 The ISP DHCP server provides settings on a different subnet. The ISP explained that this network is not intended for customers. At the moment in the logs, I see a bunch of firewall errors related to the "Default deny rule IPv4" for UDP protocol. Blocks traffic for different ports of several subnets. There are many entries in the log, new ones appear every second. Destination IP is different everywhere and they are unknown to me. Screenshot:
    Screenshot_3.jpg


  • Netgate Administrator

    That's the firewall log not the system log.

    When you set the static IP and gateway you have been given do you see errors in the system or gateway logs?

    Also I assume you have been given a /24 subnet mask?

    Steve



  • @stephenw10 I apologize for my negligence. This is what I see in the system log when I change from WAN DHCP to static ipv 4:
    Screenshot_4.jpg
    Getaway log:
    Screenshot_5.jpg
    10.66.66.x - DHCP WAN adress.
    192.xxx.xxx.xxx - my static ipv4 gateway.
    Yes, subnet mask /24.
    In Status - Gateways - Gateway 192.xxx.xxx.xxx is Offline. But, if i change static ipv4 to WAN DHCP - gateway 192.xxx.xxx.xxx is Online.


  • Netgate Administrator

    Hmm, well I'm not sure where you have made the changes but it appears not everything has changed.

    It's still trying to reach the gateway at 10.66.66.1 but can't because it no longer has an interface in that subnet.

    At some point it's trying to reach the gateway at 192.x.x.x (I assume that's a public IP otherwise there is no point obscuring it) but trying to do so from 10.66.66.75 still.

    The last entry there shows 33% packet loss to the 192 gateway. Than implies 66% packets are coming back from it.

    Does it actually show as up after a minute or so?

    Steve



  • @stephenw10 Yes, I only need to change WAN DHCP to WAN static ipv4 - these messages appear in the system log.
    My screenshot of wan setup:
    Screenshot_7.jpg
    Screenshot_8.jpg
    I really do not understand why there is no Internet via WAN... The same settings are used by my External Hyper-V Virtual Switch, and the Internet is working properly on the host. May be need more screenshots to provide more information about my pfSense network settings? Thank you for help.


  • Netgate Administrator

    Either that gateway is not responding to ping or it's not there at all.

    Is that an actual public IP or a 192.168.X.X adddress?

    Steve



  • @stephenw10 public IP. Very strange, because if i use WAN DHCP - he is Online and ping to gateway 192.xxx.xxx.x is OK.


  • Netgate Administrator

    See your other thread. Are you trying to use that same IP on pfSense and the host at the same time?



  • @stephenw10 Thank you very much for help and advice! Problem solved.


Log in to reply