Restore weirdness



  • I made a full backup of the firewall configuration from a pc running with 4 interfaces running pfsense 2.4.4 Release p1 and restoring it to a Netgate SG-8860 running pfsense 2.4.4 Release p2.

    I did a section by section restore and i cannot restore the virtual IPs and the limiters in the Traffic Shaper section.

    Has anyone experience this. What's your solution?



  • Addendum:

    I got the following error message importing Traffic Shaper:

    "An area to restore was selected but the correct xml tag could not be located."


  • Netgate Administrator

    Never restore an individual config section if the versions are different. The config version is only stored in the main system section and other sections will not be correctly converted when imported into a newer pfSense.
    Restore the complete config or upgrade the older box first to get the same config version.

    Steve


  • LAYER 8 Rebel Alliance

    Why do you restore section by section anyway?!

    -Rico



  • @stephenw10 Noted. I will try to restore the complete config and see what happens and post the outcome here.

    Thank you!



  • @Rico A little background first: netgate appliance (with six ports) running pfsense 2.4.4R1 went down bad; we cobbled up a pc with four NICs (3 WANs 1 LAN), installed same version and imported complete config but the number of interfaces were different (although the names were the same) so DHCP went to a different interface and the limiters weren't there either, anyway, we changed the xml so we restored the DHCP.

    Now, we got the netgate appliance (SG-8860) repaired, now running 2.4.4R2 and we're trying to restore backups made from the pc to the appliance.

    We got a newer netgate appliance (XG-7100) and we will eventually restore the latest backups to that unit (as soon as we get our heads around the VLANs and LAGG0 and configure its internal -- we have three WANs). Currently I'm looking at documentation and trying to read up on how to turn two ETH ports to two WANs.


  • Netgate Administrator

    Shoot us a ticket at https://go.netgate.com if you need any assistance importing that to the XG-7100.

    Steve



  • @stephenw10 Thanks! If I hit a snag I will. I still have to re-view and finish your videos and do a test setup and see is that works.


  • LAYER 8 Rebel Alliance



  • As an update to the restore procedure I did before:

    A full config backup made on a pc running pfsense 2.4.4R1 was made. The PC has 4 NICs -- 3 for WANs and 1 for LAN. The complete config was restored to a blank XG-7100 (reset to factory defaults) and I got the following error message:

    Interface mismatch detected. Please resolve the mismatch, save and then click 'Apply Changes'. The firewall will reboot afterwards.

    I took a peek and the limiters were there and the virtual IPs as well but the interfaces were in a different configuration which is understandable since it's a totally different machine. I will have to try and reconfigure the assigned interfaces and VLANs to closely match the PC's configuration.


  • Netgate Administrator

    Really though we can help you with that import if you open a ticket. We have done many of them. 😉

    Steve



  • @stephenw10 I took your advice and opened a ticket and in less than an hour the config backup from the pc was converted, sent back to me, and restored to the XG-7100 (maybe 30 minutes). So very cool! As a plus I am learning a lot from the converted backup file that Vladimir sent to me. Thanks!


Log in to reply