What is this board??? Help!

  • I have a board I cannot identify. I want to use it for pfsense so bad. After install it only shows 1 interface and cannot get link status.

    The box looks very similar to the SG-3100 but the exterior is where it stops.

    this board has a Intel atom c2358 1.7 CPU
    4gigs of RAM
    1 sfp port
    2 wan ports
    And 4 lan ports (I think they are an Intel pro 1000) but it's embedded
    An Ami aptio bios dt 2008 es 82 4493

    Looks like it used to be a velocloud edge500 sd-wan

    There's no bios id on startup or I'm the bios that I can find. I'm sure it's just a setting or a driver I need from manufacturer but don't know where to go from here.

  • You do realize that's a special purpose SD-WAN appliance, probably with some pricey subscription services tied to the hardware inside, right?




  • @akuma1x yup ;)
    How awesome of a pfsense router would this be??
    I have console access and have installed pfsense, esxi 5.5, zero shell, and now back to pfsense. All had issue detecting nic's.

  • @ChrisMontrose trying to figure out who the manufacturer of the hardware / board was...

  • Netgate Administrator

    If it's a C2K SoC it will have 4 igb NICs built in, you should see that in the boot logs. In pfSense they may well show as unattached if they have an unknown phy type.

    I imagine they are the 2 WANs, the sfp port and one to a switch for the LAN ports.

    Check pciconf -lv for other devices.

    What does the detected NIOC show for ifconfig -vm igb0? Assuming it is igb0.

    You got photos?


  • LAYER 8 Moderator

    @ChrisMontrose said in What is this board??? Help!:

    How awesome of a pfsense router would this be??

    Not that much really. Any C2xxx Atom or even better the newer C3000 Denverton Atoms would be far more "awesome" than that - especially if they somehow modified the PHY part so they won't work as igb or ix style interfaces. ;)

  • @stephenw10
    Hey Steve! Thank you so much for your reply.
    I really appreciate any help I can get.
    FYI / Warning I am new to pfsense and linux

    Ok here is a pic of the ports on the back
    alt text

    Here is the top of the board
    alt text
    i noticed in pfsense when i run
    ifconfig -vm igb0
    it shows f0:8e:db:01:29:73
    and i see this mac address on a sticker on im guessing for the 4th lan port based on this picture

    And the bottom
    alt text

    This is the readout of the console on boot with its original velocloud software before I flashed it with pfSense
    velocloud boot info.txt

    and here is the boot info with pfSense and the
    pciconf -lv and
    ifconfig -vm igb0
    commands pfsense boot info.txt

    when assigning wan interface I tried auto with no luck. When I plug a Ethernet cable from my current router lan port i get link lights on the velocloud lan ports but not the wan ports but cant get pfsense to show a link.

  • Netgate Administrator

    Ok so it's running an old OpenWRT, you could try the generic x86 image and see what happens.

    It has a Marvel switch and 4 igb NICs as expected. Three of them are not supported by the standard driver:

    device_attach: igb0 attach returned 6

    The switch is connected via Eth1?

    [    2.344164] eth1[0]: detected a Marvell m88e6176 switch

    What are the other two Marvell ICs on the bottom of the board? I'd guess they are the PHYs for the 3 non detected NICs.
    Since only one is detected I'd guess it's the SFP port but the reported media types do no reflect that in which case it may be the switch connection. Since the two WANs I would expect to be the same.

    Supported Atheros adapter is nice.

    Make sure you get that heat pad back in some useful way.


  • Netgate Administrator


    Well there's always a chance. 😉

    Getting the NICs to recognise new PHYs can be.... challenging! As can configuring the switch, which would be all command line in CE.
    I would think there's a good chance of getting OpenWRT up on it though. Better on their forum for that.

    Getting those chip IDs would be the first step.

    You might also try a 2.5 snapshot. The FreeBSD 12 drivers probably support more PHY combinations.


  • @chrismontrose So I have a few of these, did you make any progress with this?

  • Netgate Administrator

    Mmm, I'd forgotten about this.

    I have a learnt a little more since then though. To make this work with pfSense fully you would need a custom igb driver. Both because it looks like it's rejecting the PHYs attached to them in the standard driver and because you need one that has code to generate the mdio device attached to igb0 so that etherswitch can use it to setup the switch. The switch ports will remain disabled until that is done.

    If I had one I would try booting a 2.4.5p1 image and a 2.5 image to see if either have an igb driver that can see the PHYs.
    I would also try booting in verbose mode to see if any other errors are shown by the NIC driver.


  • @stephenw10 I am going to give that the good old college try.