Telekom Magenta-TV immer wieder Aussetzer



  • Hallo zusammen,

    seit nun fast 3 Monaten habe ich einen 100 Mbit Anschluss von der Telekom.
    Passend dazu habe ich ein Speedport Entry 2 und eine Hardware auf der pfsense läuft. Der Speedport wird von mir als reines Modem betrieben, alles andere was sonst der Speedport noch so tut übernimmt in meinem Fall die pfsense. Soweit funktioniert auch alles prima, selbst die Inbetriebnahme des ISDN Adapters hat fast problemlos geklappt.
    Das einzige bei dem ich langsam am verzweifeln bin ist die Gewärleistung des störungsfreien Genuss des Magenta-TV Angebotes. Leider habe ich es bis jetzt nicht hinbekommen das Angebot von Magenta-TV über dem Receiver ruckelfrei darzustellen. Mal ist stundenlang das Bild absolut flüssig, dann wieder immer mal kurze Ruckler, die sogar einen Bild-/Tovnversatz zur folge haben, bis hin zu 1 minütigen freezern die mit einer Einbledung einhergehen die sagt: "Verbindung derzeit nicht möglich".

    Ich habe schon alle möglichen Konfigurationen aus dem Netz probiert aber leider habe ich das Problem damit nicht lösen können.

    Hat von den Magenta-TV Kunden unter Euch vielleicht auch schon jemand das gleiche Problem gehabt und kann mir dabei helfen meines zu lösen?
    Langsam weiß ich nicht mehr was ich noch machen soll.

    LG, Thomas



  • Hi,

    hast du pfBlockerNG im Einsatz? Wenn ja, deaktiviere es mal bitte und teste 1-2 Tage ob dies eine spürbare Verbesserung bringt.



  • @m0nji ich habe es zwar installiert aber es der Dienst ist deaktiviert. Bevor ich es installiert habe hatte ich aber auch schon genau die gleichen Probleme, daran scheint es wohl nicht zu liegen.

    Hast du Magenta-TV bei dir über pfsense am laufen?

    LG



  • Leider kämpfe ich immer noch mit diesem Problem der kurzen Aussetzer.
    Zwischenzeitlich habe ich noch folgendes gemacht.

    • pfsense komplett neu installiert (2.4.4-RELEASE-p2 (amd64) )
    • vorher gesicherte konfiguration neu eingespielt
    • auf einer anderen Hardware installiert und auch die vorhandene konfiguration neu eingespielt
    • Mediareceiver ohne Switch und anderen Komponenten an pfsense betrieben

    Leider alles ohne Erfolg!
    Komischerweise kommen die Aussetzer nicht regelmäßig. Manchmal ist für mehrere Stunden alles i.O. und dann sind immer mal wieder Aussetzer mit unterschiedlicher Länge. Ist auch bei einigen Sendern häufiger als bei anderen. Manche sender machen gefühlt gar keine Probleme.

    Langsam gehen mir aber die Ideen aus. Vielleicht hat hier im Forum doch noch einen zündenten Einfall wie ich das Problem in den Griff bekomme. Kann doch nicht sein, dass ich der einzige bin der dieses Problem mit Magenta-TV und pfsense hat.



  • @tomxl

    könnte ein Multicast Problem sein, manche Sender nutzen auch kein Multicast. Bibel TV müsste noch Unicast sein



  • Vielleicht hätte ich mal dazuschreiben sollen um welche Sender es sich dabei handelt. :-)
    Einer der Sender die gut gehen ist "Geo" in HD. Ein Sender der viele Aussetzer hat ist "ONE" in HD.

    Ich habe zwei Mediareceiver 401. Bei beiden tritt das Problem gleichermaßen auf.
    Die Regeln für die beiden Receiver sind so eigestellt, dass bei IPV4 alle Protokolle mit allen Ports offen sind, IPV6 ist an der pfsense hingegen komplett blockiert!



  • @tomxl

    wenn du Powerline Adapter nutzt oder einen Switch zwischen geschalten hast teste mal ohne, und sonst schaue dir mal Bibel TV an auch wenn es sich komisch anhört, weil dies ist ein reiner Unicast Sender.

    Glaub man muss in PFsense auch Multicast aktivieren, habe aktuell kein Entertain um das mal zu testen.

    Sitz selber im Telekom Support und das sind so mit die Häufigsten Fehler beim Entertain TV.



  • Hier mal meine Konfig. Ich hoffe ich habe nichts vergessen.

    LAN Regel
    lan.jpg

    WAN Regeln
    wan_regel.jpg

    IGMP Proxy
    IGMP.jpg

    VLAN7
    vlan.jpg

    PPPoE
    ppp.jpg

    WAN
    wan_.jpg



  • @Chrysen said in Telekom Magenta-TV immer wieder Aussetzer:

    @tomxl

    wenn du Powerline Adapter nutzt oder einen Switch zwischen geschalten hast teste mal ohne, ...

    Hab ich doch schon weiter oben geschrieben. Hab es ohne Switch direkt an pfsense betrieben. Gleiches Ergebnis. Selbst wenn ich das mit Bibel-TV aussetzerfrei hinbekomme habe ich das Problem noch nicht behoben. Wo muss ich den dieses Multicast in pfsense aktivieren?



  • @tomxl

    habe dazu dass z.B. gefunden

    https://steffenschiffel.de/telekom-entertain-hinter-pfsense-firewall/

    bin leider selber noch nicht so der pfsense pro, des bietet so viele Funktionen ^^



  • @Chrysen Diese Seite hatte ich auch schon mal gesehen. Die Einstellungen haben mir bei meinem konkreten Problem aber nicht wirklich weiter geholfen. Was hier meiner Meinung nach noch fehlt ist das VLAN7.

    Außerdem habe ich ein gänzlich anderes Fehlerbild. Bei mir läuft ja alles, bis auf die kurzen Aussetzer in unregelmäßigen längeren (10 - 60 min) Abständen oder eben bei manchen Sendern gar keine Aussetzer.

    Ich bin für jeden weiteren Vorschlag dankbar der mich dem ruckelfreien Fernsebild ein Stück näher bringt.:-)



  • @tomxl

    Aus Telekom Hilft Forum

    hab ich noch gelesen, das hilft fals du kein BNG hast.

    Wenn du schon BNG hast hilft des nicht.

    Hat man noch keinen BNG-Anschluss (also ohne "Automatischen Internetzugang"), dann gehen die EntertainStreams über VLAN 8 und der Rest über VLAN 7. Ist es schon ein BNG-Anschluss, dann läuft alles über VLAN 7.



  • @tomxl

    Probier mal im Wan-Interface für PPPoE die MTU auf 1492 zu setzen.

    In der WAN-Firewall-Rule für UDP habe ich keine IP-Options gesetzt.

    Hardware-Offload und Co da hast du in System / Advanced / Networking mal deaktiviert?

    Warum führst du jede Nacht um 4 Uhr einen Reset der Verbindiung durch? ich habe da Dial-on-Demand aktiviert mit Idle-Time = 0 und Rücksetzen ganz deaktiviert.



  • @wkn said in Telekom Magenta-TV immer wieder Aussetzer:

    Probier mal im Wan-Interface für PPPoE die MTU auf 1492 zu setzen.

    Die Einstellung habe ich als erste verändert, leider das gleiche Fehlerbild.

    In der WAN-Firewall-Rule für UDP habe ich keine IP-Options gesetzt.

    das habe ich noch nicht verändert, werde ich aber heute abend testen.

    Hardware-Offload und Co da hast du in System / Advanced / Networking mal deaktiviert?

    Diese Einstellung habe ich wie beschrieben geändert, auch hier nach der Änderung das gleiche Fehlerbild.

    Ich glaube nicht, dass das NICHT setzen der IP-Optionen bei den WAN Firewall-Rules für UDP den Fehler behebt. Ich hatte das glaube ich schon mal probiert ohne das sich am Fehlerbild etwas verändert hat.
    Ich melde mich nach dem Test wieder hier. :-)

    VG



  • @tomxl

    Ich hatte da mal beschrieben, wo ich direkt Unterschiede zwischen meiner Konfiguration zu deinen Hardcopies sah.

    Ich denke mal, die Einstellungen der beiden MR401 ist OK? Also neueste Firmware (die ändert sich bei dem Gerät ja noch öfters) und Master/Slave (normale Kombi ist ja eher 401 mit 201)?

    Ich betreibe den MR auch hinter einer pfSense über einen Vigor 130 im Bridge-Mode. VLAN7-Tagging macht die pfSense. Mir sind da bis jetzt keine Störungen/Aussetzer aufgefallen, bei keinem Sender (ist aber auch kein "stundenlanger" Test gewesen, soviel Fernsehen schaue ich nicht).



  • @wkn
    Leider haben die von dir gegebenen Tipps nichts an dem Fehlerbild verändert.
    Nach wie vor immer noch diese Aussetzer. Wenn ich allerdings mein Modem (SP Entry2) im Routerbetrieb betreibe, also ohne pfsense, läuft Magentatv einwandfrei.

    Wenn es nicht an der Hardware liegt, was ich ja schon ausgeschlossen habe, muss es doch etwas mit der Software pfsense) oder meiner Konfiguration zu tun haben.
    Es wäre schön, wenn sich mal jemand opfern und seine funnktionierende Konfiguration posten würde.
    Am besten beginnend mit LAN über vlan-Tagging, igmp und die FW Regeln für NAT.
    Irdendwo muss ich wohl einen Fehler eingebaut haben den ich übersehen habe.



  • Es wäre schön, wenn die Fachleute unter Euch hierzu etwas sagen könnten.

    Ich weiß sonst echt nicht mehr was ich noch probieren soll.



  • Hat den nicht doch noch jemand eine Idee?

    LG, Thomas



  • Es gibt meines Wissens keinen Speedport, den man als Modem (Layer1) betreiben kann. Also wirklich als echtes Modem (ein Modem kann z.B. keine VLAN Tags setzen, weil Layer2)... Falls doch, ok. Ansonsten passiert hier ein Routing, NAT und vrmtl noch anderer Scheiß, den man nicht einstellen kann, was eben auch kaputt sein kann. Deshalb den Speedport mal gegen einen Draytek 130/165 tauschen (als echte Modems einstellbar). Autokonfiguration im Kundencanter der Telekom deaktivieren.

    Deine Upstream IGMP Proxy stimmen nicht mit denen von https://steffenschiffel.de/telekom-entertain-hinter-pfsense-firewall/ überein. Solange du Fehler hast, würde ich die offensichtlich funktionierende Konfig nutzen! VLAN 7 fehlt dort nicht, weil es in diesem Teil der Konfig schlicht nicht darum geht überhaupt ins Netz zu kommen. Allow IP Options muß gesetzt sein: "Im Option-Feld des IP-Headers wird dem Router mitgeteilt, dass er dieses Paket auswerten muss."

    Also:
    du hast 100er Anschluß, Internet geht und TV geht, wenn auch schlecht. -> VLAN7 ist vermeintlich korrekt eingestellt, VLAN8 an deinem Anschluß war nie da und es ist ein BNG.

    Grüße



  • @pfadmin said in Telekom Magenta-TV immer wieder Aussetzer:

    Es gibt meines Wissens keinen Speedport, den man als Modem (Layer1) betreiben kann.

    Der Speedport Entry 2 kann und sollte als Modem betrieben werde.
    Ein Betrieb als Router? Wer tut sich das im Normalfall an?

    LG



  • @gladius
    Danke für die Info, dass der Modembetrieb hier möglich ist. Geräte als reine Modems sind ja rar. Ich würde nach dem "Speed" schon nicht mehr drüber nachdenken :-)



  • Läuft bei euch denn der IGMP-Proxy auf dem PPPoE-VLan7-Interface? Wenn ich das bei mir als Upstream-Interface konfiguriere, verweigert igmpproxy den Start mit der Fehlermeldung "There must be at least 1 Vif as upstream", weil er PPPoE nicht als Interface mag. Prinzipiell soll es dafür ja einen Patch geben, ich habe aber keine zuverlässigen Infos gefunden, ob der es auch in die pfSense geschafft hat oder nur der Patch für das VLan-Interface-Problem (das bei Version 2.4 bestanden haben soll).

    Würde mich ja freuen, wenn mir jemand zuverlässig versichert, dass der igmpproxy auf PPPoE-Interfaces bei ihm läuft und das dann nur an meiner Config liegt.


Log in to reply