error in unifi controller due to snappy java



  • pfsense installed with Unifi controller to support switches and access points.

    when trying to add an access point i get following error.

    [2019-04-09T13:41:30,597] <inform-2> ERROR [InformServlet] - Servlet.service() for servlet [InformServlet] in context with path [] threw exception [Servlet execution threw an exception] with root cause java.lang.NoClassDefFoundError: Could not initialize class org.xerial.snappy.Snappy at com.ubnt.net.InformServlet.new(Unknown Source) ~[ace.jar:?] at com.ubnt.net.InformServlet.o00000(Unknown Source) ~[ace.jar:?] at com.ubnt.net.InformServlet.o00000(Unknown Source) ~[ace.jar:?] at com.ubnt.net.InformServlet.o00000(Unknown Source) ~[ace.jar:?] at com.ubnt.net.InformServlet.service(Unknown Source) ~[ace.jar:?] at javax.servlet.http.HttpServlet.service(HttpServlet.java:742) ~[tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:231) ~[tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:166) ~[tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52) ~[tomcat-embed-websocket-8.5.34.jar:8.5.34] at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:193) ~[tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:166) ~[tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:198) [tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:96) [tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:493) [tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:140) [tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:81) [tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:87) [tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:342) [tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.coyote.http11.Http11Processor.service(Http11Processor.java:800) [tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:66) [tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:806) [tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1498) [tomcat-embed-core-8.5.34.jar:8.5.34] at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49) [tomcat-embed-core-8.5.34.jar:8.5.34] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_202] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_202] at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61) [tomcat-embed-core-8.5.34.jar:8.5.34] at java.lang.Thread.run(Thread.java:748) [?:1.8.0_202]

    can anyone here help me with this ?



  • Hi !

    None of what you mentioned comes from pfSense.
    Don't know what an "Unifi controller" is, but I'm pretty sure that this is not their support site.



  • I have an LR at home, and I keep a Win10 VM around to host the controller software, Java, etc. I've never seen your problem nor have you given anywhere near enough information for anyone to even guess. Go to the UBNT forums and ask there.

    https://community.ubnt.com/t5/custom/page/page-id/forums



  • No i know its not coming from pfsense.
    Its a wifi controller for ubiquiti systems installed on same system as pfsense and i hoped someone here might have seen the issue before :)

    It seems to be a snappy Java issue.
    Made a post on ubnt forums also


  • Banned

    @Henrikt said in error in unifi controller due to snappy java:

    Its a wifi controller for ubiquiti systems installed on same system as pfsense and i hoped someone here might have seen the issue before :)

    No one here is stupid enough to compromise a pfSense installation by doing something moronic like that.


  • LAYER 8 Global Moderator

    Yeah, I doubt you will find much support around here for trying to run the controller on pfsense install.. Prob better help over on the unifi forums for such a thing.

    if you want to run pfsense and UC on the same hardware - then run a hypervisor and run pfsense as vm and uc as vm..

    Unlikely you would find anywhere here that actually knows what they are doing trying to help you compromise your firewall witch such an install.



  • Did you check out the issues page on github? This might be relevant:
    https://github.com/gozoinks/unifi-pfsense/issues/29



  • It seems they only really care about Windows, and Linux/FreeBSD are second-class citizens. They had an issue several months ago where you couldn't install it on Ubuntu because of a hardcoded db dependency that was no longer supported by the distro or something like that. After that I gave up and spun up a Windows VM to manage it.


  • LAYER 8 Global Moderator

    I doubt that is related... But this one might be
    https://github.com/gozoinks/unifi-pfsense/issues/134

    @KOM I have been running UC on ubuntu VM for long time, always running latest beta 5.10.21 currently... Seems can not direct up from .21 to 5.11.10? But have not had chance to look into it yet, just go back from vac..



  • @johnpoz I don't exactly remember as it was many months ago, but I think it was something to do with mongodb version-related.


  • LAYER 8 Global Moderator

    you using the ports or the download the .deb direct... I remember reading something about that - but have no run into any such issues, etc.

    Other than tried to update to 5.11.10 this morning.. Said it installed but then hit the web and got a error about can not update from .21...

    Which is why I love running this on VM, since all had to do was rollback to snap I took before tried the update ;)



  • I don't remember if I manually installed from .deb or if I found a PPA for it. I don't bother upgrading it anymore even now that it's on Windows. It's working. Last time I forgot to upgrade it the official way and ended up with an orphan on my hands that I had to quickly remember how to reconfigure while the family bitched and moaned 😆


  • LAYER 8 Global Moderator

    Well I have been running UC on ubuntu for like 4 years.. They had some issues with their repository, so I switched over to the deb many years ago..

    Its a simple wget, and then a dpkg -i to update.. Takes all of couple of minutes.. Just take a snap before do so just in case.. I have only had to revert maybe 2 or 3 times over the 4 years. And those times were me just too lazy to read the release notes before update ;)

    And I always run bleeding edge both in firmware for the AP and the UC..

    I would never run it on windows ;) That sounds like a nightmare waiting to happen.. heheheh



  • @johnpoz The Windows VM that Unifi lives on only ever runs if I have to make a change to the AP configuration. Which is never.



  • @KOM
    If you have multiple Unify APs and want to use roaming, the controller has to run all the time.



  • @viragomann Thanks, I did not know that. However, I only have the one device so I'm good.


  • LAYER 8 Global Moderator

    No it doesn't..The controller needs to run if you want to use specific features, like guest network, captive portal.. To be honest unless you want the info, you don't need the controller running.

    And to be honest you can prob run guest policies without the captive portal - just look into the selfrun mode for details
    https://help.ubnt.com/hc/en-us/articles/205222660-UniFi-Configuring-the-SELFRUN-State


Log in to reply