Unable to install any packages on XG-7100 running 2.4.5?



  • Hi,

    I have a Netgate XG-7100 running pfSense 2.4.5:

    2.4.5-DEVELOPMENT (amd64) 
    built on Thu Jan 31 05:15:48 EST 2019 
    FreeBSD 11.2-RELEASE-p8 
    

    When I try to install a package - e.g. telegraf, I get an error:

    >>> Installing pfSense-pkg-Telegraf... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    The following 2 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	pfSense-pkg-Telegraf: 0.8 [pfSense]
    	telegraf: 1.9.0 [pfSense]
    
    Number of packages to be installed: 2
    
    The process will require 64 MiB more space.
    21 MiB to be downloaded.
    [1/2] Fetching pfSense-pkg-Telegraf-0.8.txz: . done
    pkg-static: cached package pfSense-pkg-Telegraf-0.8: size mismatch, fetching from remote
    [2/2] Fetching pfSense-pkg-Telegraf-0.8.txz: . done
    pkg-static: cached package pfSense-pkg-Telegraf-0.8: size mismatch, cannot continue
    Failed
    

    I read this FreeBSD post, which seemed to suggest running pkg update -f might help:

    pkg update -f
    Updating pfSense-core repository catalogue...
    Fetching meta.txz: 100%    940 B   0.9kB/s    00:01
    Fetching packagesite.txz: 100%    2 KiB   2.3kB/s    00:01
    Processing entries:   0%
    pkg: wrong architecture: FreeBSD:12:amd64 instead of FreeBSD:11:amd64
    pkg: repository pfSense-core contains packages with wrong ABI: FreeBSD:12:amd64
    Processing entries: 100%
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue...
    Fetching meta.txz: 100%    940 B   0.9kB/s    00:01
    Fetching packagesite.txz: 100%  137 KiB  70.2kB/s    00:02
    Processing entries:   0%
    pkg: wrong architecture: FreeBSD:12:amd64 instead of FreeBSD:11:amd64
    pkg: repository pfSense contains packages with wrong ABI: FreeBSD:12:amd64
    Processing entries: 100%
    Unable to update repository pfSense
    Error updating repositories!
    

    It seems to fail due to some FreeBSD 11 or 12 error. Is this related to the move to FreeBSD 12 as the base? Is there any way to get package installation working again?

    Thanks,
    Victor


  • Banned



  • @Grimson said in Unable to install any packages on XG-7100 running 2.4.5?:

    2.4.5 doesn't exist anymore.

    Ah right - yes, I see the latest 2.4.5 build is from 11th of February.

    But 2.5.0 isn't publicly available yet, right?

    Is this the reason I can't install packages on this XG-7100? If so, is there a way to get it working for now?


  • Banned

    @victorhooi said in [Unable to install any packages on XG-7100 running 2.4.5?]

    But 2.5.0 isn't publicly available yet, right?

    https://forum.netgate.com/topic/141675/pfsense-2-5-0-development-snapshots-now-available

    [Your friendly mods at work]


  • Netgate Administrator

    Yes, the dev branch has moved to 2.5 which is built on FreeBSD 12. So to install packages you will need to either update to a 2.5 using the instructions for coming from 2.4.5 here:
    https://www.netgate.com/blog/pfsense-2-5-0-development-snapshots-now-available.html

    Or re-install 2.4.4. There is no way to downgrade easily to that from 2.4.5 in place.

    Steve


Log in to reply