Problem Solved -- Connecting to Console Port SG-1100 (Linux)



  • Running Ubuntu 18.04, attempting to connect to the Console Port (USB to Serial adapter in the SG-1100) was unsuccessful. But I found the solution. Hope this helps someone ...

    PuTTY
    I tried installing putty, but putty would not connect to the serial port. dmesg indicated that the pl2303 was being recognized, the correct driver was installed, and the port was indeed /dev/ttyUSB0. But putty failed with:

    (putty:1657) Gtk-CRITICAL ... gtk_box_gadget_distribute ... failed in GtkScrollbar
    

    I finally gave up on PuTTY.

    cu
    The cu command also failed. I tried

    $ cu -l /dev/ttyUSB0 -s 115200
    

    but even if i ran it as root (sudo ...) it failed.

    cu: open (/dev/ttyUSB0): permission denied
    cu: /dev/ttyUSB0: Line in use
    

    lsof showed that there were no processes using that device.

    screen
    I installed screen

    $ sudo apt-get install screen
    

    and then ran

    $ sudo screen /dev/ttyUSB0 115200
    

    Success! I'm in.


  • Rebel Alliance Netgate Administrator

    Yes, screen is amazing.

    This is why we suggest it in our help document:
    https://docs.netgate.com/pfsense/en/latest/solutions/sg-1100/connect-to-console.html#gnu-screen


Log in to reply