e2guardian - quando ativo filtro ssl bloqueia tudo



  • Bom dia senhores!
    Tudo bem?

    Estou com o pfsense 2.4.4-p1
    Segui todos os passos citados para a instalação do e2guardian. Está devidamente instalado. Fiz o teste de bloqueio seguido também os passos citados pelo Marcello Coutinho. Porém, quando em Groups - Groups Options - Filter ssl - Ao selecionar o mesmo, salvar e clicar em apply, ele bloqueia todo e qualquer site. Fiz um certificado interno em System - Cert Manager, habilitei como citado mas não funciona.

    Ao desabilitar o Filter ssl, ele volta a funcionar normalmente assim como os bloqueios configurados.

    Por favor, alguém teria alguma sugestão?

    Muito obrigado pela atenção

    Douglas



  • Bom dia amigo,

    Você liberou a porta 8081 no firewall?



  • @doguibnu ja passei por isso, meu problema era que tinha esquecido de instalar o certificado que o e2guardian estava usando nos computadores. instalei dai tudo funcionou normal, hoje não uso mais porque não tenho necessidade, alem de algumas funções extras que ele oferece também tem a questão de aparecer a pagina de bloqueio na HTTPS, fora isso no meu caso não vi necessidade de usar por isso desativei essa função e tudo esta funcionando bem.



  • No meu cenário funcionou bem ativando a função e sem instalar os certificados nas máquinas, e foi até por isso que optei por usar o e2guardian em vez do squid.

    Como falado, só não aparece os erros ao acessar as páginas bloqueadas, mas para mim, isso não faz diferença.



  • @obmor
    Olá tudo bem?

    Sim, eu liberei a porta (firewall - rules (8081) mas não surtiu efeito, continua tudo bloqueado.
    A não ser que eu tenha feito a regra errada

    Obrigado



  • @obmor said in e2guardian - quando ativo filtro ssl bloqueia tudo:

    No meu cenário funcionou bem ativando a função e sem instalar os certificados nas máquinas, e foi até por isso que optei por usar o e2guardian em vez do squid.

    Como falado, só não aparece os erros ao acessar as páginas bloqueadas, mas para mim, isso não faz diferença.

    Sim, a intenção é não precisar instalar o certificado em cada pc (são muitos pontos), seria apenas o bloqueio e uma página personalizada de erro, assim como o Marcello mostrou no vídeo porém, no exemplo dele funcionou perfeitamente no modo transparente. Pq não conseguimos....

    Mas ok, se não conseguir, deixarei apenas o bloqueio normalmente.

    Obigado pela ajuda!

    Douglas



  • @lotus said in e2guardian - quando ativo filtro ssl bloqueia tudo:

    @doguibnu ja passei por isso, meu problema era que tinha esquecido de instalar o certificado que o e2guardian estava usando nos computadores. instalei dai tudo funcionou normal, hoje não uso mais porque não tenho necessidade, alem de algumas funções extras que ele oferece também tem a questão de aparecer a pagina de bloqueio na HTTPS, fora isso no meu caso não vi necessidade de usar por isso desativei essa função e tudo esta funcionando bem.

    Certo então Lotus! Creio que terei que desabilitar o filter ssl então e só deixar o bloqueio normal

    Mas como que o Marcelo conseguiu, eu vi o vídeo umas 10x heheheheh pra ver se não estava esquecendo algo

    Obrigado!

    Douglas



  • @doguibnu esse é um comentário que já publiquei algumas vezes aqui no fórum, o vídeo deve ser o que você já viu.

    Para a configuração usei este vídeo que mostra as configurações básicas e depois fui só aprimorando:

    Youtube Video

    Um comentário meu complementando como filtrar o https sem instalar os certificados nas máquinas:

    "Você vai precisar gerar o certificado interno para o próprio pfsense. Não vai precisar instalar eles nas máquinas a desvantagem disso é que quando o site https for bloqueado ele não irá mostrar a página de bloqueio do E2G com o motivo de bloqueio, ele só ira exibir um erro de CONNECTION_CLOSED, mas o bloqueio funciona perfeito. Na guia DAEMON, marca lá no final da página o Enable SSL support e escolhe o certificado interno que você criou. E depois lá no Groups, edita o grupo padrão (ou os demais que você tiver) e NÃO deixa marcado a opção "Filter ssl sites forging SSL Certificates (off). E vualá deu certo com a observação citada, mas deu certo XD"

    Um detalhe que eu e outras pessoas notaram é que a primeira conexão a um site tem uma certa demora, mas depois que conecta navega de boa. Comentaram sobre desabilitar o DNS Resolver e habilitar o DNS Forwarder. Testei aqui no meu caso e deu certo.



  • @obmor said in e2guardian - quando ativo filtro ssl bloqueia tudo:

    @doguibnu esse é um comentário que já publiquei algumas vezes aqui no fórum, o vídeo deve ser o que você já viu.

    Para a configuração usei este vídeo que mostra as configurações básicas e depois fui só aprimorando:

    Youtube Video

    Um comentário meu complementando como filtrar o https sem instalar os certificados nas máquinas:

    "Você vai precisar gerar o certificado interno para o próprio pfsense. Não vai precisar instalar eles nas máquinas a desvantagem disso é que quando o site https for bloqueado ele não irá mostrar a página de bloqueio do E2G com o motivo de bloqueio, ele só ira exibir um erro de CONNECTION_CLOSED, mas o bloqueio funciona perfeito. Na guia DAEMON, marca lá no final da página o Enable SSL support e escolhe o certificado interno que você criou. E depois lá no Groups, edita o grupo padrão (ou os demais que você tiver) e NÃO deixa marcado a opção "Filter ssl sites forging SSL Certificates (off). E vualá deu certo com a observação citada, mas deu certo XD"

    Um detalhe que eu e outras pessoas notaram é que a primeira conexão a um site tem uma certa demora, mas depois que conecta navega de boa. Comentaram sobre desabilitar o DNS Resolver e habilitar o DNS Forwarder. Testei aqui no meu caso e deu certo.

    Olá!
    Sim, foi exatamente assim que procedi, como vc citou no texto. Se realmente para aparecer uma página com uma configuração mais "profi" de bloqueio e para isso necesitar instalar o certificado em cada navegador, que fique sem a opção filter ssl desabilitada.

    Obrigado

    Douglas


Log in to reply