PFSense Speed Issue



  • Morning all - This is my first clean install of PFSense and I'm having trouble with speed - we have a 160/30 FTTP Line and when I run a speedtest from CLI I get the full speed, but behind the firewall the download speed is all over the place never reaching the max.
    I have no shapers/limiters in place on the VLAN I'm testing from.

    PFSense 2.4.4 P2
    installed bare metal on:
    HP 800 G1 USDT
    Intel(R) Core(TM) i3-4130 CPU @ 3.40GHz
    240G SSD
    6GB RAM

    5 VLANs (4 LAN, 1 WAN PPPoE)

    Any assistance/advice would be greatly appreciated!


  • LAYER 8 Global Moderator

    @HenryMatter said in PFSense Speed Issue:

    I have no shapers/limiters in place on the VLAN I'm testing from.

    But you do on others? Lets be clear do you have ANY shaping or limiters setup anywhere in pfsense... Or is it green install, any packages? And how exactly is this client that is testing setup? And what browser are you using for testing? Are you saying this client tests fine for speeds if you remove pfsense from the mix?



  • Apologies - I have some limiters set up on other VLans but all are disabled for testing.
    I have Squid/Squidguard/openVPN client export packages installed.

    testing client is Win10 PC, speedtests run both through speedtest dot net and btwholesale speedtester both with varying results.

    Without PFSense the line speedtests fine

    thanks!


  • LAYER 8 Global Moderator

    Well your running this through a proxy its sounds like since you have have squid setup.



  • man - I'm embarrassed! I thought I'd disabled the proxy for testing but seems I hadn't.
    I disabled it, tests ran fine, re-enabled it and still worked - must have been a random glitch.

    thank you so much


Log in to reply