Problems sending/receiving emails with attachments



  • I have just installed pfsense 1.2.2 to server as a internet filter on our local network. Problem is now, emails with attachments of several hundred kbs or more can no longer be sent or received. Client computers are using outlook as their email client. When I you try send/receive option, it just times out after a while, with Error Number: 0x800CCC0F. Small text mails can get through. If I disconnect pfsense, everything is working ok, so the problem is somewhere in pfsense.
    Besides the default, I have installed squid, squidguard and lightsquid. They work and block properly for browsing.
    One thing I've tried, in System-Traffic Shaper and Firewall Advanced-Disable Firewall option to check this option. Then I can send/receive emails with attachments, but squidguard is not blocking anything.
    I found a very similar thread already on the forum, but there was no solution there. And with no new posts there for months I started this new thread.
    Some answers to the questions already posted in that thread:
    I haven't entered anything into MTU size.
    Max ping  packet size for our pop server is 1660, smtp doesn't respond to pings (mail server is at isp, not local).
    No I/O errors on either lan or wan interfaces.
    Both lan and wan interace are in the same subnet.
    I don't have any static routes, but still tried checking the System-Advanced-Static route filtering option. Didn't help.

    Any more suggestions?



  • Somebody somewhere reported similar problems - if you search the forums you should find it.

    I'm happily sending emails with multi-MB attachments through my pfSense box, so it's unlikely to be a pfSense specific problem.



  • As I've said, I found the other thread.

    http://forum.pfsense.org/index.php/topic,11735.0.html

    I tried everything suggested there. It didn't work. I posted my answers to things I've tried. If I just circumvent pfsense box everything works. So it must be pfsense related.



  • We had a similar issue (inbound mail was fine, couldn't send outbound attachments beyond 25k or so) that eventually traced back to a bad Ethernet port on our ISP's (XO) dual T-1 router that is in our rack.  Luckily it had two ports so we just had them move our config to the e1 port and everything straightened right out.

    The clue to look for in our case was I/O errors on the WAN interface.  If your WAN passes through a switch before your pfSense box, this might be harder to detect.  Go to the interfaces/WAN page and make sure you don't see any errors.  I would assume that LAN errors could cause similar issues.

    If you can, change out your NICs and maybe even your WAN modem/router/whatever.  Good luck.  For the record we're using Goggle Apps premier if it matters to you.



  • I have now installed pfsense on a different computer and moved it from the switch it was on. The issue still remains. Thing is I can download/upload to say rapidshare through it. I just uploaded a 15 mb file, and downloaded a 100 mb file. It's just emails that aren't working. Sending AND receiving.
    One thing I noticed on the new box, wan interface has very little traffic reported even after downloading that big file. Pic of that attached.




  • OT: Outlook has issues like this occasionally.  If you run scanpst.exe on the affected machines, you might make some progress.  There are several KB articles on the subject.

    Another easy test is to try Thunderbird, Mozilla's mail client.



  • i have different problem with attachment download from yahoo … it wont downloadable from yahoo
    there is no problem with gmail ...
    i have 2 popular that web mail ...

    that's solved ... i have to uncheck url ip filter from squidguard
    its look ... when i download attachment from yahoo, its acces from ip ... then block by squidguard

    but ... when it uncheck, firstly i checked it before to use prventif from user access ultrasurf that acces with ip base and that suck my bw ...
    any suggestion what i have todo for preventif ultrasurf so it will blocked ...

    thanks



  • What happens if you disable squid?



  • no … i wouldnot to disable squid
    since it's have solved
    just ... how to prevent ultrasurf utility ?
    because that access by ip address ...
    any idea ...


Log in to reply