Max CPU0, Miniupnpd and Synology NAS



  • My Synology NAS is requesting/extending 4 ports per 10 second for UPNP to the SG-1100, and this seems to hit the CPU0 hard. I know the quantity (2057 Ports) of UPNP is high, and I will review that behavior on the synology forum. Is the UPNP behavior unreasonable? The NAS request single ports.

    Is this just the upper limit of what this SG-1100 hardware can handle?

      PID USERNAME   PRI NICE   SIZE    RES STATE   C   TIME    WCPU COMMAND
     2833 root       -92    0 11192K  2712K CPU0    0  68.0H 100.00% /usr/local/sbin/miniupnpd -f /var/etc/mi
    

    Wireshark filter I am observing the request with:
    (udp contains "HTTP/1.1") and ((udp contains 0a:53:54:3a) or (udp contains 0a:59:54:3a))

    Thanks for comments,
    septer012


  • Netgate Administrator

    Yes, 4 ports every 10s could well be hitting the limit for continually reloading the ruleset.

    What it is doing that can possibly require that?

    Steve


  • LAYER 8 Global Moderator

    What version of dsm are you running? Do you actually need UPnP.. I would ask for what? What packages are you running? Do you have a router setup under external access in the control panel?



  • @stephenw10 Yes, thank you, that makes more sense. Adding a rule to me shouldn't be that intensive, but reloading the whole ruleset each time probably is, thanks for that. I have UPnP disabled still.

    @johnpoz DSM is 6.2.1. UPnP is certainly simpler. Packages I see I can stop, I will update DSM and all the packages, then stop them one at a time while watching the wireshark to see if any of them are offending. If not, it could be the DSM itself. The synology "community" (forum), seems under-represented. If I find out anything ill share. Thanks.



  • I shut off in this order and the UPnP request stopped on:

    • moments
    • drive
    • document viewer
    • docker
    • web station
    • surveillance station
    • photo station
    • log center
    • download center
    • OAuth Service
    • Plex

    Guess I will have to peruse the Plex logs and their forums. =-)


  • LAYER 8 Global Moderator

    Just turn off UPnP in plex - it really is simple 1 port forward... All plex needs for remote access is tcp 32400.. Unless you changed the default port, which you would just use that then.

    What version of plex are you running? Your behind on DSM which is DSM 6.2.2-24922, so I take it your behind on plex as well? I show current as 1.15.6.1079


Log in to reply