PHP Startup: Unable to load Dynamic Library. Help please



  • I needed to reboot the system for some config changes i was doing with vpn setups, but a couple hours before this i had uninstalled squid. other than these, the system had been runnning for 85 days. on reboot i get a screen full of errors as shown in attached picture

    Please advise

    IMG_20190509_2355016.jpg



  • Does everything appear to be working ok? Can you still get to WebGUI? Is there a chance it's been doing this every reboot and nobody noticed until now?

    What version of pfSense is this?



  • no it wont boot any further than the above ,and most of those options wont work, example type "16" "enter", it just backspaces the number.

    i dont think its being doing this no, though the system hasnt been rebooted in 85 days before today.

    im running 2.4.4-p1. this was its first install about a year ago, and been running great ever since. till now



  • Do you have a config.xml backup to restore from, if worse comes to worst?



  • no, but i can see the config on the drive under root when i list the dir



  • That's not where it lives so it may be good or it may be old or invalid somehow. I think the current one is under /cf/conf. Copy it off the box and verify that it looks like your config, then use it to restore a fresh installation. You could be back up in 10 minutes. If you have a spare disk, you might want to use that to restore on so that you don't slam your existing broken install, in case you need it again for some reason (custom scripts, squidguard AccessDenied images, anything that wouldn't be saved in config.xml.)

    Note: I'm not sure if package information is saved in that config, so verify that all your packages have metadata in there as well.



  • yep i can see it under cf/config

    can i attach a usb stick and copy this to it?



  • I don't know if it will automount it or if you have to fiddle with mount manually. If you have enabled SSH then I would get it that way. Otherwise, stick is your only other option.



  • im not great with linux cmds, will need some help here



  • Run:

    ls /dev/ada*
    

    and see what it says, then plug your stick in run it again. That will tell you the device. On my default install, I have ada0 and partitions 1-3. Your stick might show up as ada1.

    From there, you should be able to mount it via something like

    mount_msdosfs /dev/ada1 /media/usb
    

    assuming the USB stick is ada1.

    Then you can copy the config.xml file to the /media/usb directory.

    im not great with linux cmds

    pfSense is based on FreeBSD, not Linux, so if you're Googling then make sure you use the correct context or you will get bad results.

    I have a hockey game to go watch so I hope you're on the right track. I'll check back later to see how you made out.



  • tried that, doesnt show up?IMG_20190510_1043076.jpg



  • got it mounted, now im getting permission denied when i try to copy it



  • Dismount it and then try:

    mount -t msdosfs -w /dev/ada1 /media/usb
    

    assuming the stick is ada1. Change as necessary.



  • Same issue with my pfSense, after upgrading to 2.4.4p3 in 2 days it's dead.
    looks like pfSense files are corrupted some how or is hardware failure I suppose, but the ePSA Pre-boot System Assessment on my Dell T20 doesn't found anything suspicious (all tests even the long ones passed).

    Did you reinstall pfSense on same hardware and is working for you?



  • I done a re-install keeping my config, all went well and been running fine since.



  • Re-installed pfSense from scratch and restored the config from backup, everything is back and running.
    But this situation when for unknown reason the pfSense stopped working completely, it's a bit worrying me.


  • Rebel Alliance Moderator

    @ady2 said in PHP Startup: Unable to load Dynamic Library. Help please:

    But this situation when for unknown reason the pfSense stopped working completely, it's a bit worrying me.

    You just hopped into the thread with "me too" ;) As no one knows what exactly your problem was, one can't read minds what the reason/solution is. The error above is typical for a system that wasn't on at least version 2.4.3 and had trouble with the update. As the OP wrote he had uninstalled squid it's possible that triggered an update (from an older version, 2.4.2 or older perhaps) that had the problem with not locking various packages so they don't accidentally trigger a package update of only few packages instead of a complete update of pfSense base.


Log in to reply