Help With bug/error SQUID GUARD| Ayuda con bug/error en SQUID GUARD



  • good day, I reinstalled a backup file from a version 2.4.3 to a version 2.4.4_2 and I had errors in squid guard:

    45a7e44a-194b-4e54-a969-9b1fe2edcfcd-imagen.png

    Crash report begins. Anonymous machine information:

    amd64
    11.2-RELEASE-p6
    FreeBSD 11.2-RELEASE-p6 #4 ed5153fb2b9(factory-RELENG_2_4_4): Wed Dec 12 15:17:11 EST 2018 root@buildbot2.nyi.netgate.com:/build/factory-crossbuild-244/obj/amd64/bwlyKhYx/build/factory-crossbuild-244/pfSense/tmp/FreeBSD-src/sys/pfSense

    Crash report details:

    PHP Errors:
    [10-May-2019 15:39:20 America/Mexico_City] PHP Fatal error: Uncaught Error: Call to undefined function squidguard_before_form() in /usr/local/www/pkg_edit.php(113) : eval()'d code:1
    Stack trace:
    #0 /usr/local/www/pkg_edit.php(113): eval()
    #1 {main}
    thrown in /usr/local/www/pkg_edit.php(113) : eval()'d code on line 1
    [10-May-2019 15:41:15 America/Mexico_City] PHP Fatal error: Uncaught Error: Call to undefined function squidguard_before_form() in /usr/local/www/pkg_edit.php(113) : eval()'d code:1
    Stack trace:
    #0 /usr/local/www/pkg_edit.php(113): eval()
    #1 {main}
    thrown in /usr/local/www/pkg_edit.php(113) : eval()'d code on line 1

    No FreeBSD crash data found.

    when trying to open the squid guard this page appears

    5b8c2fd8-f20e-4253-a876-e17e2c41ee8d-imagen.png



  • @egonzalezgdl

    for SquidGuard package; ensure the tick box is checked to ensure config is kept after deinstall (by default it is) then go into package manager, uninstall the package, then reinstall it again.



  • @Mr_JinX said in Help With bug/error SQUID GUARD| Ayuda con bug/error en SQUID GUARD:

    for SquidGuard package; ensure the tick box is checked to ensure config is kept after deinstall (by default it is) then go into package manager, uninstall the package, then reinstall it again.

    Thanks for replying, I already tried to uninstall and reinstall the squid guard and continue the problem 😭



  • @egonzalezgdl I would personally install pfsense using the same version the config was created on, then do the upgrade to the latest.


Log in to reply