redirecting local access to my external ip



  • Sorry, I am not sure if I am right here.
    I access some of my services (SMTP, HTTP) from my local LAN with a URL.
    The URL is translated by a local DNS (which I can not change) to the external IP (the WAN IP).
    It seems that the traffic is forwarded to the router with that IP and then back to the LAN.

    How can I translate or redirect traffic to the external IP in pfSense directly to the LAN (pfsense) and use the pfSense-NAT-Rules, that are set up for traffic coming in from the router?

    Regards,
    Gunther





  • Hi,
    could you guide me what to do to set up NAT reflection?
    I am lost...

    Regards,
    Gunther



  • It tells you exactly what to do right there on the page:

    In order to access ports forwarded on the WAN interface from internal networks, NAT reflection must be enabled.

    In order to do this, navigate to System > Advanced, Firewall/NAT tab. On that page, select Pure NAT for NAT Reflection mode for port forwards, check Enable NAT Reflection for 1:1 NAT, and check Enable automatic outbound NAT for Reflection. Click Save.



  • yes, I did so, but I am not sure where I can set in pfSense my external IP (178.115.xxx.xxx), at the moment there is set the local IP of the pfSense-WAN-Interface (192.168.1.1) and the Gateway-Adress (192.168.1.2=LTE-Router). router forwards all traffic to 192.168.1.1, I have nowhere set, that my external IP is 178.115.xxx.xxx. So how can pfSense translate a request to 178.115.xxx.xxx to a local adress?

    Regards



  • OK, well that's a different thing. This would have been good to know in your original post.

    What are you using for DNS and why can't you change it? In your case, it might be easiest to just maintain a hosts file. A better solution would be to have your ISP flip your modem into bridged mode and let pfSense handle your public WAN IP address. You are currently in a double-NAT configuration, and this is not optimal.



  • ah, now i see the problem. double-nat.
    thanks for your help.


Log in to reply