Installing Ver 2.4.4 stops – Needs Manual root filesystem specification.

  • I have been using pfSense (up to) Ver 2.3.4 nanobsd on an APU2C4 for a couple of years now and have been very happy overall. I am now trying to do a fresh install of Ver 2.4.4 onto the same hardware as a replacement for 2.3.4. The installation proceeds nicely until I get to the point where I am requested to enter a “Manual root file system specification”. I am offered an example that suggests: ufs:/dev/da0s1a. When I try that I get an error-19 code.

    I am hoping that someone may be able to help me get past this point.

    I have some experience with Linux but a newbie when it comes to FreeBSD Labeled Filesystems.


  • I am still experiencing the problem described above. I suspect I may not have provided enough context to my description of the issue so I will try to expand on that here.

    The pfSense-CE-memstick-serial-2.4.4-RELEASE-p1-amd64.img.gz image I have placed on the mSata drive begins booting as expected and after about 30 seconds of output gets to the point where presumably it tries to mount the root file system, but in the end halts at the mountroot> prompt. I haven’t managed to direct the console output to a file so I have had to retype the last bit of the output to the following code box.

    ad0: 15272MB (31277232 512 byte sectors)
    Loader variables:
    Manual root filesystem specification:
      <fstype>:<device> [options]
        Mount <device> using filesystem <fstype>
        and with the specified (optional) option list.
       eg. ufs:/dev/da0s1a
           cd9660:/dev/cd0 ro
             (which is equivalent to: mount -t cd9660 -o /dev/cd0 /)
       ?             List valid disk boot devices
       .             Yield 1 second (for background tasks)
       <empty line>  Abort manual input

    Executing the “?” command produces the following list.

    List of GEOM managed disk devices:
    01 diskid/DISK-A1D4076419F100157321s2a
    02 ufs/FreeBSD_Install
    03 ufsid/5bfc2a8817b3588f
    04 diskid/DISK-A1D4076419F100157321s3
    05 diskid/DISK-A1D4076419F100157321s2
    06 diskid/DISK-A1D4076419F100157321s1
    07 ada0s2a
    08 msdosfs/EFISYS
    09 diskid/DISK-A1D4076419F100157321
    10 ada0s3
    11 ada0s2
    12 ada0s1
    13 ada0
    (NB: List has been formatted for clarity)

    All the 13 device labels were tried in the execution at the mountroot> prompt, in the form: ufs:/dev/diskid/DI...etc. hoping to complete the process manually with one of them.

    Devices 1, 2, 3 and 7 produced results that indicated that mounting of the devices was attempted but the shell could not be started. All the remaining devices reported a mounting failure with Error 22 returned. Any other command attempt returns Error 19.

    I do hope this might be sufficient detail to allow someone to suggest how I might get beyond this point.


  • I have made some progress. This time I zeroed out all of the mSata drive (using dd) before reinstating the image (again using dd). The mSata is now automatically mounted during the install process which now carries through to completion. I am not completely out of the woods yet. The final reboot loops back to the install routine, so I need to sort that out.

    Unfortunately this area seems to be a bit of a backwater for expert knowledge these days, but I understand why this might be so. Once you have jumped the install hurdle there are much more interesting things to be involved in.


  • I've got around 30 APU2x4 units out there and haven't had any issues but I mostly clone my msata drives from a base image. My actual installs I've done from a CD-ROM plugged into the sata port (with external power). Do you have that option?

  • @BrucexLing said in Installing Ver 2.4.4 stops – Needs Manual root filesystem specification.:

    The final reboot loops back to the install routine, so I need to sort that out.

    Try this : during the shutdown-reboot, remove the memstick ;)

  • I upgraded the Bios on my APU2 bios to v4.9.0.5 and later to v4.0.25. On both these Bios versions the 2.4.4 installation progressed passed the xterm terminal selection point to where Auto(UFS) is selectable. Beyond this point a “Device Busy” error is reported and progress is halted. While on the v4.0.25 Bios I persevered with repetitive attempts at Auto(UFS) selection and eventually it burst through the Device Busy error and progressed to a full install. At this stage I have not tried to repeat this experience. PfSense has been operational for a day now with no adverse indications. My plan now is to battle test the current 2.4.4 installation for some days and when satisfied it is solid I will go to my second mSata drive with my penultimate 2.3.4 system still intact and then replace it with a fresh 2.4.4 install, trying to replicate the “Device Busy” error and explore just what is happening there.