WAN "disabled" after adding a VIP



  • Hello everyone,
    I have experienced a very strange behaviour on my pfsense, virtual installation, version 2.4.3-RELEASE-p1 (amd64).

    My WAN in configured with a /29 public ip address; since I needed a new public ip, I added the last available ip from that subnet as VIP.
    As soon as I clicked on Apply configuration, the firewall became unreachable from WAN (reachable from lan), none of the VIP's addresses were pingable, not even the WAN interface ip address.
    WAN interface was like "disabled", no traffic at all, incoming o outgoing.

    So, I removed the last added VIP, everything started to work again; the VIP was right, legit, no mistakes.

    Any of you had ever experienced a strange problem like that?

    Thanks for your help.

    Nicola


  • LAYER 8 Global Moderator

    @Nicola said in WAN "disabled" after adding a VIP:

    I added the last available ip from that subnet as VIP.

    So the broadcast? You have/own this /29 and were just using 1 of the addresses?

    I have actually used the broadcast on a vip for a test of something, never an issue..

    I would suggest you updated to 2.4.4p2 which is current. 2.4.3 is unsupported.



  • Hello John,
    I didn't use the broadcast address, I used a "real" ip address.
    In addition to wan ip interface, I have already used 4 more vip's, so I tried to add one more, since in a /29 we can use 6 ip's.
    What do you mean that version 2.4.3 is not supported?

    Anyway, right now, while I'm writing, reviewing the firewall configuration, I just found the problem.
    I added to VIP the same ip used as gateway address for wan interface...
    This is my fault of course; I just expected some kind of control from pfsense web interface.
    Anyway, case closed.
    Thanks anyway for you reply.


  • LAYER 8 Global Moderator

    @Nicola said in WAN "disabled" after adding a VIP:

    What do you mean that version 2.4.3 is not supported?

    2.4.3 is listed as previous unsupported release...
    https://docs.netgate.com/pfsense/en/latest/releases/versions-of-pfsense-and-freebsd.html

    notsupported.png


  • LAYER 8 Moderator

    Just as I'm curious: I thought 2.4.4(-p1+) was already config rev 19.1? At last that's what my cluster systems tell me in system log?


Log in to reply