Weird 2.4.4_3 issues



  • A recently purchased SG-3100 upgraded last night from 2.4.4_2 to 2.4.4_3. No additional packages installed, most settings are default.

    First,

    • Greeted with pulsing orange square light, logged into GUI and initiated upgrade. After first reboot there was a solid orange square light, system was up, no console errors, no system log messages to correlate to this orange light... Does the light even mean anything?

    Second,

    • All clients unable to resolve domain names, "dig google.com" times out. Validated DNS settings are correct in General and DNS Resolver.

    • Restart DNS Resolver service. Name resolution is now working but extremely latent, up to 3 seconds to return results. Once cached, name resolution is fast, 1 - 2 ms.

    • DNS Lookup up under Diagnostics return sub 20ms against all DNS servers for a variety of domains that haven't been cached yet. However, from clients, dig commands against non-cached domains would take 2500 - 3000ms to complete.

    • Rebooted SG-3100 a second time, the orange square light went away. Did not notice any error or warning messages in console. DNS however was broke again, no clients could resolve. Restarted DNS Resolver service, clients resolving again however still very latent.

    • Up the logging level per DNS troubleshooting in documentation. DNS Resolver logs appear to be normal, all INFO or NOTICE logs with metrics, query and forward messages appear to be normal operation.

    • Updated settings in DNS Resolver, instead of default Network Interfaces ALL and Outgoing Network Interfaces
      ALL, changed to Network Interfaces LAN and Outgoing Network Interfaces WAN. DNS resolution is fast again for all lookups.

    Some suggested that DNS over TLS was enabled, it is not. DNS Query Forwarding forwarding mode is disabled and use SSL/TLS is disabled.

    Lastly,

    • Status/Monitoring broke, zero data returned, graph is stuck at displaying 2001-11-05 -- 2001-11-06 no matter what I change the view to.

    If there is any details I can gather please let me know. Hopefully I can revert the settings and recreate the latent resolutions if needed.



  • Experiencing similar issues with DNS lookups intermittently timing out since upgrading to 2.4.4_3. Using DNS Resolver. No prior DNS issue(s) identified on 2.4.4_2.



  • Switching to 2.5.0-DEVELOPMENT version has resolved client DNS issue.



  • Fresh install of 2.4.4-RELEASE-p3 has solved the issue of DNS lookups randomly timing out. Apparently updating from 2.4.4-RELEASE-p2 to 2.4.4-RELEASE-p3 broke something.



  • As I posted https://forum.netgate.com/topic/142290/traffic-graphs-widget-does-not-work-on-the-dashboard/3

    I had a similar situation after upgrading to 2.4.4._3, where my Traffic Graphs on multiple sites would not start/would not diplay any bandwidth. I'd see 1 dot of Zero and then the graph would not update and further. I tried rebooting, and editing the graph by removing all and saving and then adding them all back and saving, but no change.

    I then tried to add JUST WAN. That graph works now! I tried adding them one by one, and saving after each. They are all workign now. This might be a solution. There must be an array that gets reset to zero or something, and adding one to the array sequentially allows it to udpate them all (eventually). On my main site I can only add 6 graphs (my other sites have only 6 interfaces ), so myabe there is a 6 limit not (Intential or otherwise).

    HTH,
    Peter



  • Well 2.4.4_3 just took a hard fail:

    Welcome to pfSense 2.4.4-RELEASE (Patch 3)...

    ...ELF ldconfig path: /lib /usr/lib /usr/lib/compat /usr/local/lib /usr/local/lib/ipsec /usr/local/lib/perl5/5.26/mach/CORE
    Soft Float compatibility ldconfig path:
    done.
    Removing vital flag from php72... done.

    Fatal error: Uncaught Error: Call to undefined function gettext() in /etc/inc/certs.inc:46
    Stack trace:
    #0 /etc/inc/functions.inc(32): require_once()
    #1 /etc/ecl.php(21): require_once('/etc/inc/functi...')
    #2 {main}
    thrown in /etc/inc/certs.inc on line 46
    Launching the init system...
    Warning: Failed loading Zend extension 'opcache.so' (tried: /usr/local/lib/php/20131226/opcache.so (Cannot open "/usr/local/lib/php/20131226/opcache.so"), /usr/local/l0

    Warning: PHP Startup: Unable to load dynamic library 'session.so' (tried: /usr/local/lib/php/20131226/session.so (Cannot open "/usr/local/lib/php/20131226/session.so")

    With about 50 more lines of php failing to load libraries.

    Doing a search in forums shows this as some bug seen under 2.5 DEVELOPMENT... I have a 2.4.4_p2 recovery image. going to revert later today. I can't be down this bad testing 2.4.4_p3.



  • @jasont said in Weird 2.4.4_3 issues:

    Warning: Failed loading Zend extension 'opcache.so' (tried: /usr/local/lib/php/20131226/opcache.so (Cannot open "/usr/local/lib/php/20131226/opcache.so"), /usr/local/l0
    Warning: PHP Startup: Unable to load dynamic library 'session.so' (tried: /usr/local/lib/php/20131226/session.so (Cannot open "/usr/local/lib/php/20131226/session.so")
    With about 50 more lines of php failing to load libraries.

    Strange.

    On a 2.4.4-RELEASE-p3 there is only this folder :

    /usr/local/lib/php/20170718/
    

    with the PHP libabries.
    and not that very ancient

    /usr/local/lib/php/20131226/
    

    That one should have been ditched during a past upgrade.

    Don't work on it. Take a config backup - and re install from scratch.



  • I have re-updated to 2.4.4_3. I was consoled in and there were no error messages. The strange solid orange square light was not there after the upgrade like it was the first time I went through it. I have not experienced DNS resolution issues either. I will assume my first time upgrading was faulty.

    My SG-3100 started off with 2.4.4_1 and I updated from p1 to p2 to p3.

    The second time I reinstalled starting at p2 and upgraded to p3... I will keep my eyes out for this 20131226 php version.. I validated that I am 20170718 currently with no old 20131226 directory.

    Question: Do I need to submit another ticket to request access to a 2.4.4_3 image? Keep on doing that moving forward?



  • Switched back to 2.5.0-DEVELOPMENT version as client DNS issue soon reappeared on 2.4.4_3.


Log in to reply