[SOLVED] Netgate Coreboot Upgrade says MTB-2220 isn't Netgate hardware



  • We have a Netgate MBT-2220 running pfSense 2.4.4-RELEASE-p3 in a test lab and have installed the Netgate Coreboot Upgrade package. When we try to use it, it reports "This function is only available for Netgate Inc. hardware". The MBT-2220 is Netgate hardware and, as I understand, it uses Coreboot. Why are we getting this error message?


  • Netgate Administrator

    The Minnowboard boxes do not use Coreboot as shipped. There is no upgrade available for them so that package reports an error. I agree the message is misleading though. We have an internal bug opened for it.

    It is possible to run Coreboot on Minnowboard though I'm not sure the dual Ethernet boards are compatible. I would not recommend it unless you have a means to reflash it if/when it fails to POST.

    Steve



  • @stephenw10 Thank you for that clarification. I had read in the specifications that the Minnowboards run Coreboot, and I didn't know it was optional.


Log in to reply